Freetype linking error w/ 0.062, Xcode 3.2.6, iOS4.3 Device

Hi folks,

So I’m getting a linker error when trying to build for iOS4.3:

ld: in /Users/user/Code/git/KonkreetLabs/of_preRelease_v0062_iphone_FAT/apps/iPhoneSpecificExamples/PerformerBeta/../../../libs/freetype/lib/iphone/freetype-iphone.a, file is universal but does not contain a(n) armv7 slice for architecture armv7  

Previously when building for iOS 4.2 (with Xcode 3.2.5) for the iPad it was no problem. Similarly now in Xcode 3.2.6, I can build against iOS 4.3 for the simulator no problem (I guess cos the simulator uses the MacBook Pro’s Intel architecture and not the iPad’s ARM v7 architecture).

I’m using the downloaded OF 0.062 and it’s the first time I’ve come across this error.

Anyone else seen this?

Can’t you just uncheck “only build for active architecture”? I’m still pretty new to this ARM thing, so I dunno.

Hi, no, it makes no difference. The iPad is ARM v7, so it’s looking for something that should be there, but for some reason it only looks for this with iOS 4.3 and not 4.2… :?

EDIT - OK I have arm6 & arm7 lib files for:


Tested in Xcode 4 / SDK 4.3 = Working!…-s/

If the link expires I’ll host elsewhere.

Thank you for helping us compile openframeworks in Xcode 4 with the iOS 4.3 SDK.

EDIT: heads up - the link is broken.

Not sure if you get notification that I edited so I’m posting a new reply - please try again, new link above. File has been updated with other libs. Tested and working for me now.

Thanks again for updating all the libs. Unfortunately, I’m still getting a page not found error when I click your link. If you email it to me, I’ll mirror the file for you.

BTW, checked out your apps. Glitchbeam is fantastic.


Here’s the weird part - the link doesn’t work for me either but, if I hit refresh the download begins. Must be a squarespace glitch… try it again and if it doesn’t work I’ll email it to you.

The link does not work for me … maybe it is because it is a zip


Just copy and paste the link in your browser address bar and press enter. Download should begin. Tested in Safari and FireFox. When you click the link - it breaks. Not sure why… can’t get to this for several hours, @ work.

[quote author=“Jason Walters”]EDIT - OK I have arm6 & arm7 lib files for:


Tested in Xcode 4 / SDK 4.3 = Working!…-s/

If the link expires I’ll host elsewhere.[/quote]
:slight_smile: That fixed it - just needed the FreeType and FreeImage - didn’t need Glu - thank you so much!

Any idea what was going on there, why iOS4.3 was complaining?

In the meantime, I also tested one of the OF0.062 demo iPad apps with 4.3 and it worked ok, so there was probably something not right with the build settings.

Would love to get to the root cause of this, even though it’s working now!

Well our files only had slices for arm6 and it looks like arm7 is forced or required for 4.3.

That worked fine, thanks for saving us some time Jason.

No problem! :smiley:

anyone else getting inverted colors with this new free image?

Yeah, presumably because I hadn’t applied the previous fix to the ofImage loading and saving routines

IOW I did theo’s suggestion:±iphone-sdk-4-beta-works-with-ofxiphone/3658/27

I had already implemented Theo’s fix so I hadn’t noticed. Is it working OK now?

Hi Jason, just wanted to say thanks again! and also to ask how did you build the libs for armv7, just in case I need to do it myself, and to save bothering you…?

PS: I did some more testing and it really does appear that something changed between Xcode 3.2.5/SDK 4.2 and Xcode 3.2.6/SDK 4.3 - the former could build to armv7 target fine and didn’t care about the libs, but the latter needed your libs. I assume Xcode 4/SDK4.3’s going to be the same, i.e. need your armv7 slice libs.

Oh, one more thing - the new lib won’t work with the simulator build, only the device build. At the moment I have to manually swap the old lib and new lib in and out depending on my target. Is there a way around this?