Fonts inclusion

Hi everyone,
I’ve a quick question. I am testing OF for android for the first time. I managed to run the app on my phone but the fonts are not displayed.
Do I need to move them somewhere else or should they keep on staying in the bin/data ?
the font is a simple HelveticaNeueLTStd-Roman.otf and HelveticaNeueLTStd-Bd.otf
( I tried ttf, same result. the app runs but no fonts displayed…)

any hints anyone?

cheers!:sun_with_face:

Hi, I also tested OF on android for the first time today using Android Studio.

For me, It worked fine by just keeping the font in the bin/data.

When you load the font, did you use absolute path?

I just wrote the file name like below and it worked.

font.load("Sansation.ttf", 30);

hi @cuinjune
The font is loaded like you do. I actually amended the loadFont into load but still I get the same error.

make[2]: *** No rule to make target bin/data/Arial, needed by ofdataresources.zip. Stop.

It stops compiling as soon as it tries to lead the fonts. If I remove the fonts files from the folders it compiles and installs the app without fonts though…

cheers

@cuinjune
I think I sorted this out. It was a problem with file naming. It didn’t like spaces and dash, meh!:expressionless:
all good now…
thank you!

1 Like