Font set spaces size

Hi, I’m using the method setSpacesSize http://openframeworks.cc/documentation/graphics/ofTrueTypeFont.html to change the dimension of the space between the words. It looks like it has no effect, I’ve tried with different fonts but I’ve always the same result. Am I doing something wrong?

ofTrueTypeFont font;
font.loadFont("OpenSans-Regular.ttf", 30);
font.setSpaceSize(3.0);

Are you using master/0.9-nightly build? If so, can you report on github? Mine doesn’t seem to work, either. Apparently things have changed a bit, @arturo?

yes, nightly build. I will open a new issue.

The issue is fixed on the master branch https://github.com/openframeworks/openFrameworks/issues/4400

In the nightly of 31-10-2015 the font.setLetterSpacing(float); does not work. Changing this value don’t change the font rendered. Here my code:

font.load("BEBAS.ttf", _fontSize, true, false, true, 0.4, 72);
font.setSpaceSize(0.8);

i’m testing it and it’s working for me fine

hmmm, I want to increase the space between words in a sentence, is it this method supposed to do this? If not, how can i do it otherwise?

yes but it’s doing that for me, can you post a smal example that shows the problem?

Ok, problem solved. I’ve read the docs of setSpaceSize and getSpaceSize, and I’ve thought that setting space size to 2.0 will make a space big as 2 p between the words, but that was not happening.
Here 3 screenshots, with relative code, the last one does what i want:

font.load("verdana.ttf", _fontSize, true, false, true, 0.4, 72);
font.setSpaceSize(2.0);


font.load("verdana.ttf", _fontSize, true, false, true, 0.4, 72);
font.setSpaceSize(8.0);


font.load("verdana.ttf", _fontSize, true, false, true, 0.4, 72);
font.setSpaceSize(28.0);