Finding the good config in "project settings"

Hi !

I don’t know why but I have always same errors and nothing happen.
I’m sure that’s a simple issue.
Help PLEASE !!

I tried the 0.05, 0.06, 0.07 version and always same errors :

you are compiling against a really old verison of OSX sdk, which looks problematic (I see 10.4 in the screenshot). What OS / Xcode are you using?

My OS is 10.6.8 and Xcode is 3.2.6
Should I try to find the 10.6 sdk ?

Yes, you should definitely upgrade to at least the 10.6 SDK. If you can manage to upgrade to at least osx 10.7, your life with openFrameworks will become much easier :smile:

I cheked in the /Developer/SDKs file and I have the 10.6 SDK but Xcode
seems to don’t find it.
How can I tell to Xcode to link this SDK ?

1 Like

In xcode , go to build settings, then there should be a section called “base sdk”, change it to 10.6

1 Like

Hi !
I have a good news ! Nothing works at all but most of time I have only 1 or 2 errors when I try to build a project.
Also I found where to specify the base SDK !
Sure it’s a simple trick.
Now I have this error message, maybe it speaks to you :

My config is : Mac OSX 10.6.8, Xcode 3.2.6, OF_PreRel_007

Thank’s fo your help.

Even when I use the last of 0.8 it makes the same problem.
I think my config is the problem, maybe I need to restart the config from 0 ?

is it always possible to use OF with 10.6, Xcode 3.2.6 ?

I solved my problem, simply reinstalled Xcode 3.2.6.
I have always a lot of warning, anyway…

But I have to juggle with the “project settings” > build > Architecture, Bas SDK and C/C++ Compliler Version.