Fedora 15/ OpenFrameworks

I have all of the required dependencies, so this should compile according to the readme, however OF isn’t having it. I just spent too long getting libfreenect/libusb running on this bastard… anyone know why it can’t find the “codeblocks-*.tar.gz” ?

i am new to this codeblock stuff, but I do have the latest version installed,

thanks!
-Trent

./install_codeblocks_svn.sh ERROR

  
|| find "codeblocks-10.05svn7520" -type d ! -perm -755 \  
	-exec chmod u+rwx,go+rx {} \; -o \  
  ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \  
  ! -type d ! -perm -400 -exec chmod a+r {} \; -o \  
  ! -type d ! -perm -444 -exec /bin/sh /root/rpm/codeblocks/install-sh -c -m a+r {} {} \; \  
|| chmod -R a+r "codeblocks-10.05svn7520"  
tardir=codeblocks-10.05svn7520 && /bin/sh /root/rpm/codeblocks/missing --run tar chf - "$tardir" --exclude=".svn" | bzip2 -9 -c >codeblocks-10.05svn7520.tar.bz2  
{ test ! -d "codeblocks-10.05svn7520" || { find "codeblocks-10.05svn7520" -type d ! -perm -200 -exec chmod u+w {} ';' && rm -fr "codeblocks-10.05svn7520"; }; }  
mv: cannot stat `codeblocks-*.tar.gz': No such file or directory  
error: File /root/rpm/SOURCES/codeblocks-10.05svn7520.tar.bz2: No such file or directory  
error: cannot open codeblocks-*.src.rpm: No such file or directory  
error: File not found by glob: codeblocks-*.i386.rpm  
[root@theo fedora]# ls  
  

./install_dependencies.sh ERROR:

  
In file included from ../../../openFrameworks/sound/ofSoundPlayer.h:32:0,  
                 from ../../../openFrameworks/app/ofAppRunner.cpp:5:  
../../../openFrameworks/sound/ofOpenALSoundPlayer.h:14:19: fatal error: AL/al.h: No such file or directory  
compilation terminated.  
make: *** [obj/Debug/openFrameworks/app/ofAppRunner.o] Error 1  
there has been a problem compiling Debug OF library  
please report this problem in the forums  
  

I haven’t tested fedora in a while. If you can install codeblocks 10.05 from the repo then you don’t need to execute install_codeblocks at all. The other problem seems to be that the install_dependencies script is not installing openAL which is a new dependency. Try to install that package manually, it should be something like:

yum install openAL-devel

I already had everything under yum openal*, and codeblocks 10.0.5;

are you on 32 or 64bit? which openframeworks version do you use? the 007 package from the website or the github master branch?

/edit/

ok, I just saw you used the codeblocks_svn.sh script.
Unfortunately, the most recent sh scripts for fedora are not in the 007 package from the website (and not in 0062). maybe you can try the github version from here https://github.com/openframeworks/openFrameworks/downloads
?