Fedora 13 install_codeblocks_svn.sh fail

I ran into a problem with the install_codeblocks_svn.sh

Fedora 13
codeblocks 10.05
openFrameworks .62

Note(?update of docs?): the readme.txt and install directions are out of date in so far as the shell script names and there are now 3 .sh scripts formerly 2. Slightly different names.

I ran the 802 script but suspect I didn’t need to as I saw some discussion about an older version, 8.02, of codeblocks. ??

I am user jeffa. I became root ( su - ) and ran the install_codeblocks_svn.sh

make[2]: Leaving directory `/root/rpm/codeblocks/src/scripts'  
 (cd wxsmith && make  top_distdir=../../codeblocks-10.05svn6859 distdir=../../codeblocks-10.05svn6859/src/wxsmith \  
     am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir)  
make[2]: Entering directory `/root/rpm/codeblocks/src/wxsmith'  
make[2]: Leaving directory `/root/rpm/codeblocks/src/wxsmith'  
make[1]: Leaving directory `/root/rpm/codeblocks/src'  
test -n "" \  
	|| find "codeblocks-10.05svn6859" -type d ! -perm -755 \  
		-exec chmod u+rwx,go+rx {} \; -o \  
	  ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \  
	  ! -type d ! -perm -400 -exec chmod a+r {} \; -o \  
	  ! -type d ! -perm -444 -exec /bin/sh /root/rpm/codeblocks/install-sh -c -m a+r {} {} \; \  
	|| chmod -R a+r "codeblocks-10.05svn6859"  
tardir=codeblocks-10.05svn6859 && /bin/sh /root/rpm/codeblocks/missing --run tar chf - "$tardir" --exclude=".svn" | bzip2 -9 -c >codeblocks-10.05svn6859.tar.bz2  
{ test ! -d "codeblocks-10.05svn6859" || { find "codeblocks-10.05svn6859" -type d ! -perm -200 -exec chmod u+w {} ';' && rm -fr "codeblocks-10.05svn6859"; }; }  
mv: cannot stat `codeblocks-*.tar.gz': No such file or directory  
error: File /root/rpm/SOURCES/codeblocks-10.05svn6859.tar.bz2: No such file or directory  
error: cannot open codeblocks-*.src.rpm: No such file or directory  
error: File not found by glob: codeblocks-*.i386.rpm  

It looks like the script is looking in the wrong directories. I found the files. sub directory SOURCES does not equal sub directory codeblocks.

[root@saturn fedora]# find / -name "codeblocks-*.tar*" -print  
[root@saturn fedora]#   

If I’m correct about the problem with the .sh instll script can someone please help me with some corrections?

Thanks! - jeffa

exactly same problem here but running on Fedora 10 i686.

does someone have any idea about why this is happening?

thanks in advance.

This morning I attempted a kludge / hack

I copied the codeblocks-10.05svn*.tar.bz2 file to the SOURCES directory and re ran install_codeblocks_svn.sh. It ran a lot farther but errored again:

./cbplugin.h:54: error: forward declaration of 'struct cbStatusBar'  
cbstatusbar.cpp:142: error: invalid use of incomplete type 'struct cbStatusBar'  
./cbplugin.h:54: error: forward declaration of 'struct cbStatusBar'  
cbstatusbar.cpp:149: error: invalid use of incomplete type 'struct cbStatusBar'  
./cbplugin.h:54: error: forward declaration of 'struct cbStatusBar'  
make[3]: *** [cbstatusbar.lo] Error 1  
make[3]: *** Waiting for unfinished jobs....  
make[3]: Leaving directory `/root/rpm/BUILD/codeblocks-10.05svn6895/src/sdk'  
make[2]: *** [all-recursive] Error 1  
make[2]: Leaving directory `/root/rpm/BUILD/codeblocks-10.05svn6895/src/sdk'  
make[1]: *** [all-recursive] Error 1  
make[1]: Leaving directory `/root/rpm/BUILD/codeblocks-10.05svn6895/src'  
make: *** [all-recursive] Error 1  
error: Bad exit status from /tmp/root/rpm/rpm-tmp.fHKVqG (%build)  
RPM build errors:  
    Bad exit status from /tmp/root/rpm/rpm-tmp.fHKVqG (%build)  
error: File not found by glob: codeblocks-*.i386.rpm  

I created two install log .txt files redirecting standard in and out. The first from the run before I manually copied the .tar file. The second after the copy where the install went further. Both are attached.

Is there a ‘better’ or more ‘propper’ place to report this bug?

c ya… - jeffa

hmm… Let me try those attachments again…

ohh… the extension txt is not allowed. I’ll gzip them.

ok whatever. After gziping I get: “Sorry, the board attachment quota has been reached.”

Not positive if that refers to my quota or the beginners forum quota.

in my endless strugles with phpBB I, me!, jeffa! will dominate! <- frustration with phpBB can’t ya tell?

I put the two log fils on github https://github.com/jhalbrecht/jOpenFrameworks

c ya… - jeffa

exactly the same thing happened to me … had the same idea of moving the file to its proper place but then a “bad exit” error occured.

meanwhile i’ve managed to solve my problem by installing codeblocks v.8.02 and using oF v0.06.

oF 0.05, 0.061, 0.062 and github versions were not able to do the job.

now i can run examples without problems on fedora 10 i686 using CB 8.02 and oF 0.06, even with errors occuring during the install_dependencies script build. :slight_smile:

well … it all sums up to try&error and lots of patience. :shock:

Is there no current version of Codeblocks in the fedora repos?
failing that, there’s a 10.05 binary on the CB page which should be sufficient.
I don’t really see if there are any problems with oF, but if so, try with the version from github, many bugs have been fixed.

p.s. posting in several forums won’t get you farther :wink: