Fatal error: gst/gst.h: No such file or directory

Just installed 007. Ran the first addons example and received this error:

  
fatal error: gst/gst.h: No such file or directory  

referencing the #include in /openframeworks/video/ofGstUtils.h

What am I missing here?

Looks like gstreamer is not installed. What distro are you using and did you run the install_dependencies.sh as root script for it? (under scripts/linux/ubuntu or debian or whatever…)

I’m receiving this same error when I run sudo ./install_dependencies.sh

I’m compiling 007 under Ubuntu 11.10

  
In file included from ../../../openFrameworks/video/ofGstVideoPlayer.h:3:0,  
                 from ../../../openFrameworks/video/ofVideoPlayer.h:9,  
                 from ../../../openFrameworks/video/ofVideoPlayer.cpp:1:  
../../../openFrameworks/video/ofGstUtils.h:5:21: fatal error: gst/gst.h: No such file or directory  
compilation terminated.  
make: *** [obj/Debug/openFrameworks/video/ofVideoPlayer.o] Error 1  

Everything compiled fine when I became root:

  
  
$ sudo su  
$ ./install_dependencies.sh  
  

I wonder if anybody else was able to figure out what the issue was (or if someone else encountered the same problem and fixed it some way other than by simply doing a sudo). I seem to be having the same problem and it does not suffice to simply run it as root, I still get the same error.

'm compiling 007 under Ubuntu 11.10.

Just to illustrate, here are the last lines of the output when I run ./install_dependencies:

  
Package gstreamer-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-0.10' found  
compiling object for  ../../../openFrameworks/video/ofVideoPlayer.cpp  
mkdir -p obj/Debug/openFrameworks/video  
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../assimp/include -I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/libpng15 -I../../../cairo/include/pixman-1 -I../../../cairo/include/cairo -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../freetype/include/freetype2/freetype/internal -I../../../freetype/include/freetype2/freetype/internal/services -I../../../glew/include -I../../../glew/include/GL -I../../../kiss/include -I../../../portaudio/include -I../../../rtAudio/include -I../../../tess2/include -I../../../poco/include -I../../../glu/include -I../../../openFrameworks/ -I../../../openFrameworks/events -I../../../openFrameworks/video -I../../../openFrameworks/3d -I../../../openFrameworks/sound -I../../../openFrameworks/utils -I../../../openFrameworks/types -I../../../openFrameworks/math -I../../../openFrameworks/communication -I../../../openFrameworks/app -I../../../openFrameworks/gl -I../../../openFrameworks/graphics   -MMD -MP -MFobj/Debug/openFrameworks/video/ofVideoPlayer.d -MTobj/Debug/openFrameworks/video/ofVideoPlayer.d -o obj/Debug/openFrameworks/video/ofVideoPlayer.o -c ../../../openFrameworks/video/ofVideoPlayer.cpp  
In file included from ../../../openFrameworks/video/ofGstVideoPlayer.h:3:0,  
                 from ../../../openFrameworks/video/ofVideoPlayer.h:9,  
                 from ../../../openFrameworks/video/ofVideoPlayer.cpp:1:  
../../../openFrameworks/video/ofGstUtils.h:5:21: fatal error: gst/gst.h: No such file or directory  
compilation terminated.  
make: *** [obj/Debug/openFrameworks/video/ofVideoPlayer.o] Error 1  
there has been a problem compiling Debug OF library  
please report this problem in the forums  

Thanks!

hm, that’s strange. it should install gstreamer0.10-ffmpeg, not gstreamer-0.10 (there’s no package with that name. can you post the second line of your install_dependencies.sh (the one where it says apt-get install…) so we can check what the script wants to do?
you are running the script from scripts/linux/ubuntu/, right?

gstreamer-0.10 is the pkg-config package name not the apt one, and it should be there. Can you try to execute the apt-get lines from the install_dependencies script in a terminal and see if they finish without problem

sudo should work ok, there shouldn’t be no need to become root

Thanks for all the replies guys. The headache ultimately got too big and before I saw your replies, I decided to do a clean install of an older version of Ubuntu and that seems to have done the trick. I was able to quickly install everything without a single issue on Ubuntu 10.10. I’m not sure if the os release plays any role in the problem (probably not), but in any case, everything works fine now.

I believe I tried that before finally giving up and all apt-get lines ended up with an “already installed” outcome.

Now just for the record, a while ago I had tried to install gtk but ran into some issues while installing glib and that may have been the reason why I just couldn’t install the OF dependencies using the script.

Thanks everyone!

how to solve the error its not working even by changing to sudo

and when i try to run the make file i get this error fatal error: avformat.h: No such file or directory

please help

can you post the error you are getting

./…/…/libs/openFrameworks/video/ofVideoPlayer.h:9:22: fatal error: gst/gst.h: No such file or directory
compilation terminated.

the problem should be that the dependencies are not being installed properly, can you execute the apt-get portion of the install_dependencies script manually and post the output:

sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libavcodec-dev libavformat-dev libavutil-dev libswscale-dev freeglut3-dev libasound2-dev libxmu-dev libxxf86vm-dev g++ libgl1-mesa-dev libglu1-mesa-dev libraw1394-dev libudev-dev libdrm-dev gstreamer0.10-ffmpeg libglew1.5-dev libopenal-dev libsndfile-dev libfreeimage-dev libcairo2-dev libgtk2.0-dev libjack-dev python-lxml python-argparse

i installed it manually still the same problem and for the installation part it says its already in the newest version
while building inside code blocks

  
  
-------------- Build: Debug in windowExample ---------------  
  
Compiling: src/testApp.cpp  
In file included from ../../../libs/openFrameworks/ofMain.h:40:0,  
                 from /home/swaroop/Downloads/of_preRelease_v0.06_linux_cb_FAT/apps/examples/windowExample/src/testApp.h:5,  
                 from /home/swaroop/Downloads/of_preRelease_v0.06_linux_cb_FAT/apps/examples/windowExample/src/testApp.cpp:1:  
../../../libs/openFrameworks/video/ofVideoPlayer.h:9:22: fatal error: gst/gst.h: No such file or directory  
compilation terminated.  
Process terminated with status 1 (0 minutes, 4 seconds)  
1 errors, 0 warnings  
   
  

this is what i got while running the makefile from terminal

  
../../../libs/openFrameworks/video/ofUCUtils.cpp:19:22: fatal error: avformat.h: No such file or directory  
compilation terminated.  
make: *** [obj/Debug/libs/openframeworks/video/ofUCUtils.o] Error 1  
  

it seems you are using OF 0.06 which is a really old version, can you download 0.07 and try again

Thanks arturo it works fine with of007

I’m getting:

  
fatal error: gst/gst.h: No such file or directory   

when running the kinectExample.

I haven’t tried all of the examples, but I don’t get the error in anything else.

I’m running of08 on Linux Mint 15 64-bit. Both are fresh installs as of today.
I ran ./install_dependencies.sh as root.

Any help is greatly appreciated.

try to have both 0.10 and 1.0 versions of gstreamer installed

I’ve been having similar troubles while trying to get ofxFaceTracker to work. There have been path issues with almost all the libraries. For instance, it expects the gst folder in /usr/include/gstreamer-1.0 to be in usr/include. Each time this would come up, I’d copy the contents to the expected location, but there always seems to be more issues. First the issue was with cairo, then gstreamer (I have 0.10 and 1.0 installed), glib, ofxCv, etc. I’m using Ubuntu 13.04 and oF 0.8. install_dependencies ran fine, but oF expects them to be in different folders. Could this be a problem with the way apt-get or Ubuntu installs libraries? Any help is extremely appreciated and please forgive my obvious n00bness.

thisw problem with the kinectExample is related to a missing library, you can install it by doing:

sudo apt-get install libusb-1.0-0-dev

in other cases it’s almost always surely related with some missing library, check the full makefile output not only the last few lines and you’ll see at the beginning it’ll tell you which packages are missing.

we will make this message more obvious for the next release