"Failed to get remote object proxy" issue

hello again :slight_smile:
I got issue with video play (youtube) in macOS xcode. (stable release 0.10.1 from openframeworks.cc)

I have no problem in linux(manjaro distro) x oF nightbuild (from git).

unlike linux, I got another error message from xcode console.
I can hear sound(!) but not video.
here’s a error message.

2019-07-20 00:31:36.761168+0900 2019youtubeTest[2280:96189] sendMessageWithDictionary: Failed to get remote object proxy: Error Domain=NSCocoaErrorDomain Code=4097 "connection to service named com.apple.rtcreportingd" UserInfo={NSDebugDescription=connection to service named com.apple.rtcreportingd}
[warning] ofGLRenderer: draw(): texture is not allocated
2019-07-20 00:41:11.213019+0900 2019youtubeTest[2551:117867] [default] Invalid display 0x533f0642
[warning] ofGLRenderer: draw(): texture is not allocated
[ error ] ofAVFoundationPlayer: initTextureCache(): error creating texture cache from image -6661.

I googled and guess it related with something security by apple, probably??

I checked that option. but nothing changed…

ok … with ofxGstreamer instead of default videoPlayer, I can play without issue.

Maybe there is a problem with the proxy setting! If so, you need to reconfigure it! The proxy server can be set up in the system settings on a personal computer or laptop. The big plus here is that no additional software is needed. There is also a disadvantage - this method allows you to organize an anonymous connection only through one intermediary server. If you are going to use a proxy pool, it does not work with the system parameters. I would be too lazy to do all this, so my choice falls on the already prepared proxy: https://soax.com/malaysia-proxy. Proven option! If the problem is different, it’s worth talking to some programmer!