Failed to compile projectGeneratorSimple with the latest OF on github

Dear EVERYBODY

update
The tar.gz package is fine to compile projectGeneratorSimple. And the one doesn’t work out is the master branch commit 2be8ada7.

Now I am an OF newbie with the tar.gz package!
etadpu

Today is my second day trying to make friend with OF. We had some good time on OS X. But … Alright, hereunder is my situation:

The version of OF I git clone --recursive is commit 2be8ada7. I tried to compile projectGeneratorSimple on Ubuntu 14.10 w/ g++ 4.9.2. But I got error messages as below. The error message, in general, is like error: ‘mouse<This mouse is having a lot of fun>’ is not a member of ‘ofxBaseGui’.

In file included from ../../../libs/openFrameworks/utils/ofURLFileLoader.h:2:0,
                 from ../../../libs/openFrameworks/types/ofBaseTypes.h:6,
                 from ../../../addons/ofxGui/src/ofxBaseGui.h:4,
                 from ../../../addons/ofxGui/src/ofxBaseGui.cpp:1:
../../../libs/openFrameworks/events/ofEvents.h: In instantiation of 'void ofRegisterMouseEvents(ListenerClass*, int) [with ListenerClass = ofxBaseGui]':
../../../addons/ofxGui/src/ofxBaseGui.cpp:107:55:   required from here
../../../libs/openFrameworks/events/ofEvents.h:282:49: error: 'mouseEntered' is not a member of 'ofxBaseGui'
  ofAddListener(ofEvents().mouseEntered,listener,&ListenerClass::mouseEntered,prio);
                                                 ^
../../../libs/openFrameworks/events/ofEvents.h:283:48: error: 'mouseExited' is not a member of 'ofxBaseGui'
  ofAddListener(ofEvents().mouseExited,listener,&ListenerClass::mouseExited,prio);
                                                ^
../../../libs/openFrameworks/events/ofEvents.h: In instantiation of 'void ofUnregisterMouseEvents(ListenerClass*, int) [with ListenerClass = ofxBaseGui]':
../../../addons/ofxGui/src/ofxBaseGui.cpp:114:57:   required from here
../../../libs/openFrameworks/events/ofEvents.h:318:52: error: 'mouseEntered' is not a member of 'ofxBaseGui'
  ofRemoveListener(ofEvents().mouseEntered,listener,&ListenerClass::mouseEntered,prio);
                                                    ^
../../../libs/openFrameworks/events/ofEvents.h:319:52: error: 'mouseExited' is not a member of 'ofxBaseGui'
  ofRemoveListener(ofEvents().mouseEntered,listener,&ListenerClass::mouseExited,prio);
                                                    ^
../../../libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:260: recipe for target '../../../addons/obj/linux64/Release/ofxGui/src/ofxBaseGui.o' failed
make[1]: *** [../../../addons/obj/linux64/Release/ofxGui/src/ofxBaseGui.o] Error 1
make[1]: Leaving directory '/home/drewfle/Downloads/openFrameworks/apps/projectGenerator/projectGeneratorSimple'
../../../libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:126: recipe for target 'Release' failed
make: *** [Release] Error 2
there has been a problem compiling the projectGenerator
please report this problem in the forums

Hi,

Unless you need a feature that is being worked on in the repository I would recommend using the latest 0.8.4 release. Especially if you are just starting out with oF.
There are some big changes flying around at the moment so the master branch is very much in flux.

Hey,

the master branch mirrors the current development of oF, therefor it can be unstable from time to time.
There is also a lot going on right now, so the current master differ greatly from v0.8.4

I dont think, that this is a OS specific issue, but git something to do with this PR. If you pull the master on OS X, you should get similar issues, right? I started a discussion with the author of the PR yesterday, but then I suddenly got it to work. But after pulling today it seems to bring up similar errors like you get. Maybe its a good idea to move this issue to github?

If you want to fetch the same stable version from github, as you got with the tar.gz package, you can check out the tag like this:

git checkout tags/0.8.4

It should work like expected.

Thank you. I’ll move my message to github!