Failed installation with msys2 on Windows 10

Hi!

I followed the guideline to install OF with msys2 on Windows but got stuck at the level of the compilation of the library.
I end up with make giving this error:

HOST_OS=MINGW32_NT-10.0
makefileCommon/config.shared.mk:217: *** This package doesn't support your plateform, probably you downloaded the wrong package?.  Stop.

I am using the mingw32_shell.bat and I used the v0.9.3_msys2_release

Any idea?

Best,
Guillaume

Hi, same problem here with 9.8 using windows 8. Anyone can help out?

I will add my woes to this small group of unfortunates. I trying to use the OF 0.9.8 for msys2 on windows 10. i followed the directions on the msys2 setup page and got as far as compiling the libraries. my install of msys2 did not have mingw32_shell.bat so i ran “C:\msys64\msys2_shell.cmd -mingw32”.
when i ran make in the project directory it returned the same error Guillaume is getting…
I’ve been trying to puzzle through config_share,mk file. i did notice that when i ran ‘uname -s’ from a shell, it returns MSYS_NT-10.0 and msys2 shell returns MINGW32_NT-10.0. i have no clue if that is significant.
looking further at config_share.mk, it says:
else ifneq (,$(findstring MINGW32_NT,$(PLATFORM_OS)))
PLATFORM_LIB_SUBPATH=msys2
else ifneq (,$(findstring MSYS_NT,$(PLATFORM_OS)))
PLATFORM_LIB_SUBPATH=msys2
else ifneq (,$(findstring MINGW64_NT,$(PLATFORM_OS)))
PLATFORM_LIB_SUBPATH=msys2

so it should be catching either of those values, and there is a msys2 directory inside the project directory.

It seems that the same problem has happened in windows 7, and the OF version is 0.9.8.

error info:

HOST_OS=MINGW64_NT-6.1
makefileCommon/config.shared.mk:217: *** This package doesn’t support your platform, probably you downloaded the wrong package?。 Stop。

I try to find out the reason of this error, so I have read the config.share.mk code too, and I find that:

ifeq ($(wildcard $(OF_LIBS_OF_COMPILED_PROJECT_PATH)/$(PLATFORM_LIB_SUBPATH)),)
$(error This package doesn’t support your platform, probably you downloaded the wrong package?)
endif

It seems that our result of

$(wildcard $(OF_LIBS_OF_COMPILED_PROJECT_PATH)/$(PLATFORM_LIB_SUBPATH))

is null, so it gave us that error info.

I add some code for show related info:

$(info OF_LIBS_OF_COMPILED_PROJECT_PATH=$(OF_LIBS_OF_COMPILED_PROJECT_PATH))
$(info PLATFORM_LIB_SUBPATH=$(PLATFORM_LIB_SUBPATH))
$(info OF_LIBS_OF_COMPILED_PROJECT_PATH_FULL=$(wildcard
$(OF_LIBS_OF_COMPILED_PROJECT_PATH)/$(PLATFORM_LIB_SUBPATH)))

then we can see that:

OF_LIBS_OF_COMPILED_PROJECT_PATH=/e/Office Software/OpenFramework/of_v0.9.8_msys2_release/libs/openFrameworksCompiled/project
PLATFORM_LIB_SUBPATH=msys2
OF_LIBS_OF_COMPILED_PROJECT_PATH_FULL=

Note that there are a blank in my path “/e/Office Software/OpenFramework/”, I guess this is the reason of our error.
So I changed my path to “/e/Office_Software/OpenFramework/” and there is no blank.
And then I found that my compilation process can go on.

NOTE:
8.12_22:29:
Now I meet more errors:

make[2]: *** [makefileCommon/compile.core.mk:241:/e/Office_Software/OpenFramework/of_v0.9.8_msys2_release/libs/openFrameworksCompiled/lib/msys2/obj/Debug/libs/openFrameworks/3d/of3dPrimitives.o] error 1
make[1]: *** [makefileCommon/compile.core.mk:213:Debug] error 2
make: *** [makefileCommon/compile.core.mk:229:all] error 2

8.13_10:43
I have solved the previous problem:
I found that I was using the MINGW64.exe when I meet this errors, so I try to use MINGW32.exe to make the OF project, then I compiled successfully.

This is my solution about this question.
Good luck!

2 Likes