Failed:can't install dependencies.sh

Hi,

for install openFrameworks v0.8.1 for RASPBIAN WHEEZY at Raspberry pi B+.
did bellow,

~/openFrameworks/scripts/linux/debian_armv6l $ sudo ./install_dependencies.sh

However responsed

Note, selecting 'gstreamer1.0-omx-dbg' for regex '1.0-omx'
Note, selecting 'gstreamer1.0-omx' for regex '1.0-omx'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 gstreamer1.0-omx-dbg : Depends: gstreamer1.0-omx (= 1.0.0.1-0+rpi13rpi1) but 1.2.0-1 is to be installed
E: Unable to correct problems, you have held broken packages.
error installing gstreamer, there could be an error with your internet connection
if the error persists, please report an issue in github: http://github.com/openframeworks/openFrameworks/issues

still can’t solved issue, please advice for me.

0.8.1 is pretty old and unmantained, 0.9 has lots of fixes and should work fine. also if you ned compatibility with the 0.8.x series 0.8.4 is much newer and should work better than 0.8.1

you can also use the latest install_dependencies script in 0.9 with older versions

1 Like

Thank you for your reply !
I did complete install with Jessie and oF0.9arm6.
http://openframeworks.jp/setup/raspberrypi/Raspberry-Pi-Getting-Started.html guide using old Ver…