external addon examples don't compile [solved]

Dear OF-friends,

I am doing my first steps coming from Processing switching to OF.
While all standard examples compile and work right away I have huge problems to compile any other (addon) examples I find on the internet. For example, I tried to get ofTheo-ofxControlPanelDemo to work - unsuccessfully. Also I failed with several other examples, e.g. ofxGui.

I use of_preRelease_v007_osx on a Mac+Lion.

The first error I encounter is the one of a missing base SDK. I fixed that by setting the base SDK to 10.6 in the build Settings. Also I changed the Architecture-ReleaseUniversal to 32 bit instead of ppc.

However, if I try to compile now, I get 255 errors. The first few:

  
  
/../../libs/openFrameworks/utils/ofConstants.h:101:22: error: GL/glew.h: No such file or directory  
../../../libs/openFrameworks/utils/ofConstants.h:155:24: error: tesselator.h: No such file or directory  
In file included from ../../../libs/openFrameworks/ofMain.h:47,  
                 from /Applications/of_preRelease_v007_osx/apps/examples/ofTheo-ofxControlPanel-3e63090 3/src/testApp.h:3,  
                 from /Applications/of_preRelease_v007_osx/apps/examples/ofTheo-ofxControlPanel-3e63090 3/src/testApp.cpp:1:  
../../../libs/openFrameworks/graphics/ofCairoRenderer.h:4:28: error: cairo-features.h: No such file or directory  
../../../libs/openFrameworks/graphics/ofCairoRenderer.h:5:23: error: cairo-pdf.h: No such file or directory  
../../../libs/openFrameworks/graphics/ofCairoRenderer.h:6:23: error: cairo-svg.h: No such file or directory  
../../../libs/openFrameworks/graphics/ofCairoRenderer.h:7:19: error: cairo.h: No such file or directory  
  

Sorry, i don’t know how to display them here otherwise (subquestion: how do export errors nicely from XCode?).

To me as a beginner, this seems as if I have to add some search paths somewhere, but I have no idea where.

I would very much appreciate if you could point me into the right direction.

Thank you a lot !
Hanna

hey there,

One important thing to note is that OF is designed to be self contained, and that new projects have to be at the same depth as the other examples that ship with OF. (ie, they reference the libs folder like …/…/…/). If you don’t put a project at the right height, it won’t compile.

the first thing to look at with your xcode project is if anything in the sidebar is red. are there missing files?

Another thing to note is that project files you find might not be 007 specific – so if you try to load a 0062 project in 007, it might not work. I suspect that’s the case with the example you have from theo’s github:

https://github.com/ofTheo/ofxControlPanel

poking around, I saw this and thought you might have good luck with kyle’s branch of that addon:

https://github.com/ofTheo/ofxControlPanel/pull/19
https://github.com/kylemcdonald/ofxControlPanel

hope this helps!
zach

thanks zach!

indeed, the 007 version by kylemcdonald (https://github.com/kylemcdonald/ofxControlPanel) compiled without errors - exactly what I needed to continue…

thanks again :slight_smile:
iohanna