Exhausting all GPU memory on Pi?

Is there a way to expand the amount of memory available to the GPU for textures? If I create textures or Fbos with a total exceeding 1920x1080, they simply appear as empty or occasionally as gray boxes when drawn to screen.

What is your RAM / GPU memory split?

Seems like your memory split is insufficent. Run “sudo raspi-config” go to Advanced Settings->Memory Split and set it to 256MB. That should be enough for FullHD+ textures and is what I usually use. Though you are free to use an even larger split.

Whatever the default is (I don’t have it in front of me).

I didn’t know you could adjust that–I’ll give it a shot tomorrow!

64MB is the default. If you have an “old” Pi B+ and run into issues with not having enough system memory you could probably also just use 128MB. I think I only really needed 256MB for ofxOMXPlayer.

Thanks, setting it to 256 solved the problem!