.exe and run (build) keeps crashing when going to fullscreen

Hi all,

ive made a particle system from tutorials, it worked and tried to implement full screen option to it with this tutorial openFrameworks tutorial series - episode 023 - fullscreen - YouTube
all 3 (fullscreen) options gave same result when entering the fullscreen: the screen went “blank”, distorted and not working.

Then i tried to copy all files from (domestikaApps/FinalProject at main · paul-ferragut/domestikaApps · GitHub) repo for the project to see if it was working and to some how to find solution from there. I made 2 classes for that (particle and vectorField) and they worked fine until i tried to enter fullscreen mode (when on run mode). Same result: the screen went “blank”, distorted and not working.

I also “scanned” my laptop with intel "software to see if there were some drivers etc to be updated, nada…

Could someone give some advice where to start troubleshooting? Im lost with this one.

Thank you in advance.

Hey @skatronix , what happens when you add the following to one of the examples, maybe the /graphics/polygonExample:

void ofApp::keyPressed(int key){
    if(key == 'f'){

It seems like the problem might be outside of the app if this produces an unexpected result. When things aren’t working correctly, it sometimes it helps to start with a very simple project and slowly add complexity, with adequate testing along the way.