exclude some .cxx in ofxARTollKitPlus to compile

I’m trying to use ofxARToolKitPlus in Ubuntu 12.04 and i’m looking in the example for windows https://github.com/nestgomez/ofxARToolkitPlus- in which not all files are included, if you include all these files you get errrors. In the config.make i add this line :

  
USER_CFLAGS =   -I /home/walter/OF0072/openFrameworks/addons/ofxARToolkitPlus/include   

but this is not sufficient because i need to exclude some file in addons/ofxARToolkitPlus/src…
how van i solve this?

try mine
https://github.com/fishkingsin/ofxARtoolkitPlus

https://launchpad.net/artoolkitplus

I am testing the linux 32bit project

just take more time

cheers

Thanks! But the linux 32bit lib works also for 64 bit system? I tryed to build it before but i get problems to build it. Anyway i will try your version.
Cheers
Walter

p.s. but with which version do you build the lib? ArtoolKitPlus 2.1.1?

i got this errors in ubuntu 64bit :

Using makefile: Makefile
find: “…/…/…/addons/ofxARtoolkitPlus/libs/*/lib/linux64”: File o directory non esistente
linking x86_64 bin/ofxArtoolKitPlusExample_debug linux64
obj/x86_64Debug/addons/ofxARtoolkitPlus/src/ofxARToolkitPlus.o: In function ofxARToolkitPlus::setup(int, int, std::basic\_string<char, std::char\_traits<char>, std::allocator<char> >, std::basic\_string<char, std::char\_traits<char>, std::allocator<char> >)': /home/walter/openframeworks0071/examples/addons/ofxArtoolKitPlusExample/../../../addons/ofxARtoolkitPlus/src/ofxARToolkitPlus.cpp:63: undefined reference toARToolKitPlus::TrackerMultiMarker::TrackerMultiMarker(int, int, int, int, int, int, int)’
/home/walter/openframeworks0071/examples/addons/ofxArtoolKitPlusExample/…/…/…/addons/ofxARtoolkitPlus/src/ofxARToolkitPlus.cpp:86: undefined reference to `ARToolKitPlus::camera::printSettings()’
collect2: ld returned 1 exit status
make: *** [bin/ofxArtoolKitPlusExample_debug] Errore 1
Process terminated with status 2 (0 minutes, 1 seconds)
2 errors, 0 warnings

even if i set C_FLAGS and LIB_FLAGS:

# USER_CFLAGS allows to pass custom flags to the compiler
# for example search paths like:
# USER_CFLAGS = -I src/objects

USER_CFLAGS = -I/home/walter/openframeworks0071/addons/ofxARtoolkitPlus/libs/ARToolKitPlus/include

# USER_LDFLAGS allows to pass custom flags to the linker
# for example libraries like:
# USER_LDFLAGS = libs/libawesomelib.a

USER_LDFLAGS = -L /home/walter/openframeworks0071/addons/ofxARtoolkitPlus/libs/ARToolKitPlus/lib/linux/libARToolKitPlus.so

looking better in your repo , i saw that you used ARToolKitPlus 2.3.0, so i compiled a 64bit version and addded to the addon in this folder:

~/openframeworks0071/addons/ofxARtoolkitPlus/libs/ARToolKitPlus/lib/linux64

then in config.make:

USER_CFLAGS = -I~/openframeworks0071/addons/ofxARtoolkitPlus/libs/ARToolKitPlus/include

USER_LDFLAGS = -rdynamic -L~/openframeworks0071/addons/ofxARtoolkitPlus/libs/ARToolKitPlus/lib/linux64

and works perfectly!
but i have to had in bin directory of the example also the libARToolKitPlus.so file don’t know why…

I didnt test with the linux 64 bit version
but the step should be the same

  1. download ARToolkitPlus library
  2. ccmake ARToolkitPlus/
  3. configure your platform
  4. cmake ARToolkitPlus/
  5. make libARToolKitPlus.so
  6. copy and paste to addons/ofxARToolKitPlus/libs/ARToolKitPlus/lib/linux64 folder
  7. do the step as you mention

I thinks everything so be fine

kalwalt:
could you push your commit to the repo
thanks
since i dont have 64bit linux right now
i cant test with that

kalwalt:
could you push your commit to the repo
thanks
since i dont have 64bit linux right now
i cant test with that

Yes, of course! But i didn’t build the lib with boost enabled. Do youn think it’s better build it with boost enabled?

i’ve forked your repo and i send to you a pull request with my modifications.
Cheers
Walter