Examples show black screen

I’m using Linux Mint 17.2 and I installed dependencies using the instructions provided in the tutorials (i.e., using install_dependencies.sh in the scripts directory). For example, I compiled the graphicsExample using “make” without any compilation errors and then ran “make run”. A window appears titled “graphics example” but it is all black. This happens with other examples as well. Any ideas?

Hi, same problem here . Did you manage to run an examples ?

E

Unfortunately I was not able to run any of the examples. I didn’t spend any time debugging which probably will yield some insights.

Having the same issue here. Any workarounds? Do your own apps run correctly?

I’m having the same problem. I get a black window and nothing happens when creating an openframeworks application.

Im using openframeworks version 0.9.0 on a Lenovo laptop running Linux Mint 17.2. The graphics card is an integrated intel graphics card.

Here is the output when starting the application with OF_LOG_VERBOSE:

HOST_OS=Linux
HOST_ARCH=x86_64
checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gl glu glew gtk+-3.0 libmpg123 
[verbose] GL Version:3.0 Mesa 10.1.3

And here is the output of glxinfo:

~ $ glxinfo | grep -i opengl
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Broadwell 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.3
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.1.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
~ $ 

I’m using the following main function to start the application:

#include "ofMain.h"
#include "ofApp.h"

//========================================================================
int main( ){
        ofSetLogLevel(OF_LOG_VERBOSE); 
    ofSetupOpenGL(720, 720, OF_WINDOW);            // <-------- setup the GL context

        /*
        ofGLWindowSettings settings;
        settings.setGLVersion(3,2); /// < select your GL Version here
        ofCreateWindow(settings); ///< create your window here
        */
        // this kicks off the running of my app
    // can be OF_WINDOW or OF_FULLSCREEN
    // pass in width and height too:
    ofRunApp(new ofApp());

}


Short update (2016-01-18):
I ran some audio examples and one could hear, that the application is running correctly. It reacts to user input and the sound is played, only the graphics are not rendered on screen.
I ran apitrace to debug the application. When replaying the captured trace, everything is visualized correctly.
It seems, that somehow, the window created by openframeworks doesn’t render the output correctly, but I couldn’t find any error message in the recorded trace.


I’m not familiar with opengl programming and debugging, therefore I don’t know where to start my search to fix the problem.
Has anyone an idea.

Regards,
Stefan.