Examples Fail to Compile under Ubuntu Karmic

I downloaded and installed v0061 FAT from: http://www.openframeworks.cc/download

Ran install.sh as root, install went fine as far as I could see, fired up codeblocks, went to several of the example folders and was invariably greeted with:

  
  
-------------- Build: Debug in fontsExample ---------------  
  
Compiling: src/main.cpp  
Compiling: src/testApp.cpp  
Linking console executable: bin/advancedEventsExample_debug  
/usr/bin/ld: cannot find -lopenFrameworksDebug  
collect2: ld returned 1 exit status  
Process terminated with status 1 (0 minutes, 1 seconds)  
1 errors, 0 warnings  
   
  

What’s up?

you are missing the OF library, it should be compiled when running as root the install_dependencies.sh script, or you can open the codeblocks project in libs/openFrameworksCompiled/projects/linux and compile it from codeblocks, you’ll need to compile both debug and release

a third option is to open the workspace instead of the cbp file in the examples, that will compile the library automatically when needed

Hi,

i have the same problem, i run both scripts and got the same error. But i will try last step tomorrow, when i am back on my linux-machine.

thanks.

@phrontist @circassia

make shure that the install scripts run without errors. if errors occur, report them here.

ben

hi @phrontist,

i had the same problem, i was doing everything right. even after installing both sh files

./install_codeblocks.sh
./install_dependencies.sh

it didn’t compile. After many days i’ve recognized that i have the wrong architectur :frowning: my pc is 64bit but ubuntu was installed 32bit. Arturo told me that command

uname -a

if it says i686 than you have 32bit.

Now with the right architecture every example is compiling without any problem.

By the way, check if you have owner rights in the OF root directory. I got error messages from codeblocks, that files couldn’t created.

Chown -R yourUsername : / directoryname

Hope that helps you.

thanks

Taking another stab at this… here’s the output I’ve been getting.

http://pastebin.com/1vRJRv2X

it seems you’re getting some problem related with the latest versions of ffmpeg. this should be solved already in github, can you try with that version:

http://github.com/openframeworks/openFrameworks

Hi,
I have been trying to install OF in Ubuntu 9.10 for a while. I have tried Code::Blocks and makefile in the terminal, but I keep getting the same error:

  
/usr/bin/ld: cannot find -lopenFrameworks  

when compiling.

Can anybody help me? I’ve tried installing and deinstalling code::blocks (it installs svn build 6181) with no luck.

Here is a fragment of what I get in the terminal using the makefile:

…/libs/openFrameworksCompiled/lib/linux -L…/…/…/libs/poco/lib/linux -L…/…/…/libs/rtAudio/lib/linux -L…/…/…/libs/unicap/lib/linux -s -lopenFrameworks -lfmodexp -lfmodex -lfreeimage -lfreetype -lGLee -loFappsink -lPocoFoundation -lPocoNet -lPocoUtil -lPocoXML -lRtAudio -ldcam -lunicap -lv4l2cpi -lv4l -lvid21394 pkg-config gstreamer-0.10 gstreamer-video-0.10 gstreamer-base-0.10 libudev --libs -lglut -lGL -lasound
/usr/bin/ld: cannot find -lopenFrameworks
collect2: ld returned 1 exit status
make: *** [bin/polygonExample] Error 1

Thank you,

Esteban

can you post the output of the install_dependencies script?

I think the problem is that with the 0061 version from the downloadpage codeblocks settings are wrong.
Under build options -> linker settings -> link libraries there are correct entries for openFrameworks library. in debug there is openFrameworksDebug and in release openFrameworks. But there is also an openFrameworks entry for all configurations. So the linker takes first the libraries for all configuration.

I had to remove under all configuirations the openFrameworks lib to be able to link in debug mode.