Examples compile, but don't run, on Ubuntu 17.10

I’ve been using openFrameworks successfully for a few years on Ubuntu 14.04 LTS and 16.04 LTS, usually with Intel NUC boxes. Today I thought I’d give Ubuntu 17.10 a try - it’s beatiful! - and yet I cannot get openFrameworks examples to work at all.

My process:

  1. Fresh install of Ubuntu 17.10
  2. Everything updated
  3. Downloaded latest linux64 release from site and extracted
  4. Ran install_dependencies, install_codecs and compileOF no problem at all - no compiler errors
  5. Entered an example (it doesn’t seem to matter which one) and ran make - once again no compiler errors
  6. Tried to run with make run

Get this output all the time:
checking pkg-config libraries: cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl rtaudio gl glu glew gtk±3.0 libmpg123
Segmentation fault (core dumped)
/home/random/of_v0.9.8_linux64_release/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:169: recipe for target ‘run’ failed
make: *** [run] Error 139

Is there something I’m missing here? I know Ubuntu has switched desktops (Unity to GNOME) but does that mean openFrameworks is broken now?

Hmmm. Curious.

I noticed that if I log out and switch from “Ubuntu” to “Ubuntu on Xorg” then everything works as expected. So there is an issue using Wayland vs Xorg (X11), then?

Even weirder, though, is that once I have run something under Ubuntu on Xorg, I can log out and back in again with “Ubuntu” (Wayland) and then the very same example runs just fine. Huh?

Related to Wayland support? ?

i don’t see the same error in your output but what i’m getting lately is a problem with glfw not closing some watch on some device file or something like that. raising the number of possible watches in the system fixes it:

echo 32000 | sudo tee /proc/sys/fs/inotify/max_user_watches

Hmm, nope. Fails with the same error even after running that command (at least with “Ubuntu”/Wayland; “Ubuntu on Xorg” works just fine as before).