Example not showing up when executed

Hi,

I’m running into an issue where I can’t seem to run the example successfully. I wish there was an error but it’s rather silent.

Here are my (Relevant) machine specs:

  • Latest Ubuntu Stable fully updated
  • Ubuntu unity 7.3.1
  • Intel® Haswell Mobile Graphic Card

I followed the guide here: http://www.openframeworks.cc/setup/linux-codeblocks/

I ran the following scripts to complete the installation:

cd your_oF_directory/scripts/linux/ubuntu
sudo ./install_codeblocks.sh
sudo ./install_dependencies.sh
if you want to have support for mp3 and some video codecs:
sudo ./install_codecs.sh

Then I compiled all the examples using the script to do so.

./buildAllExamples.sh

And it completed without errors (Just warnings).

Then I went into a few video or GL examples but they seem to hangout and not do anything (either with ./binaryToExecute or make RunRelease ). Then I tried a different approach with Code::Blocks, but same thing. No errors, but no Viewport or anything.

I also tried to strace the execution (noise1dExample):

[...]
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\34\0n\0\6\0\240\4N\1\0\0\33\207\257\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 128
recvmsg(3, 0x7fff1cf9be80, 0)           = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}], 1, 4294967295) = 1 ([{fd=3, revents=POLLIN}])
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\34\0s\0\6\0\240\4\326\1\0\0\34\207\257\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32
recvmsg(3, 0x7fff1cf9be80, 0)           = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}], 1, 4294967295

Edit:

Added some logging (should have done that in the first place.), and it’s blocking on that line:

ofSetupOpenGL(1024,768, OF_WINDOW); // (Also tried OF_FULLSCREEN)

Also, searching from that point brought me there:

Could it be my problem? It should be fixed in unity 7.3.1?


Thanks!

Xavier

yes, there’s a problem in ubuntu 14.10 where apps will hang on start, you can use a glut window which will solve it. also in ubuntu 15.04 it’s already solved

Amazing, that worked.

Thanks!