Errors using ofxOpenCV

Hello,

I’ve just compiled the oF polylineBlobsExample that uses ofxOpenCV but when I run the sample I get a black screen
and a lot of warnings in the console:

  
  
[warning] ofAppEGLWindow: init(): X11 not availble on RPI yet, using a native window instead  
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 1280x720  
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 640x480  
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display  
[notice ] ofAppEGLWindow: createSurface(): EGL Display correctly set  
[notice ] ofAppEGLWindow: createSurface(): current renderer type: GL  
[notice ] ofAppEGLWindow: createSurface(): default renderer detected  
[notice ] ofAppEGLWindow: createSurface(): surface created correctly  
[notice ] ofAppEGLWindow: createSurface(): API bound correctly  
[notice ] ofAppEGLWindow: createSurface(): -----EGL-----  
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MAJOR = 1  
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MINOR = 4  
[notice ] ofAppEGLWindow: createSurface(): EGL_CLIENT_APIS = OpenGL_ES OpenVG  
[notice ] ofAppEGLWindow: createSurface(): EGL_VENDOR = Broadcom  
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION = 1.4  
[notice ] ofAppEGLWindow: createSurface(): EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface   
[notice ] ofAppEGLWindow: createSurface(): GL_RENDERER = VideoCore IV HW  
[notice ] ofAppEGLWindow: createSurface(): GL_VERSION  = OpenGL ES-CM 1.1  
[notice ] ofAppEGLWindow: createSurface(): GL_VENDOR   = Broadcom  
[notice ] ofAppEGLWindow: createSurface(): -------------  
[notice ] ofAppEGLWindow: setupPeripherals(): peripheral setup complete  
[notice ] ofAppEGLWindow: setupNativeUDev(): created udev object  
[notice ] ofAppEGLWindow: setupMouse(): mouse_fd= 5 devicePath=/dev/input/by-path/platform-bcm2708_usb-usb-0:1.2:1.1-event-mouse  
[notice ] ofAppEGLWindow: setupMouse(): mouse device name = HID-compliant Mouse HID-compliant Mouse  
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard_fd= 6 devicePath=/dev/input/by-path/platform-bcm2708_usb-usb-0:1.2:1.0-event-kbd  
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard device name = HID-compliant Mouse HID-compliant Mouse  
[notice ] ofAppEGLWindow: setupPeripherals(): native event setup complete  
[notice ] ofAppEGLWindow: setupOpenGL(): peripheral setup complete  
[notice ] ofAppEGLWindow: runAppViaInfiniteLoop(): entering infinite loop  
[notice ] probing devices with udev...  
[ error ] ofGstVideoGrabber: initGrabber(): no devices found, exiting without initializing  
[notice ] ofAppEGLWindow: runAppViaInfiniteLoop(): setting up notifications complete  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded  
  

How can I get past this issue ?

Also, a bit off topic, after installing oF and codeblocks the automatic login stopped working:
I got stuck at a login screen in an endless loop (login screen > insert user/pass > login screen > repeat).
I used Ctrl+F3 and then raspi-config to disable automatic boot with startx. Any workarounds for this ?

Thanks

do you have a webcam connected? seems like the app is looking for a camera but cannot find one

Thanks for the tip Arturo, will try with a camera attached.

However, I get the same message with the opencvExample which should open a video file.
Is this normal ? Am I missing something (perhaps with GSVideo) ?

the openCvExample may be a different issue. It uses an old codec - this file (recompressed as an .mp4) seems to work better

http://www.jvcref.com/files/PI/video/fingers.mp4.mov

Thank you both !
Using the mp4 compressed file worked just fine.