Errors trying to control webcam settings

I have been looking at posts on the forum regarding changing settings for logitech webcams (a c920 in my case)
like these:

http://forum.openframeworks.cc/t/best-usb-hd-webcam-with-control-on-osx-or-alternatives/11832/0
http://forum.openframeworks.cc/t/uvc-camera-control-in-mac-os-x/3917/3

I’ve tried to use the ofQTKitGrabber to call videoSettings();

  
  
vidGrabber.setGrabber((ofPtr<ofQTKitGrabber>) new ofQTKitGrabber());  
  

but I get a QTKit alert saying that the settings can only be used if the app is compiled with the 10.6 sdk and is not supported when the app is compiled with 10.7+
I’m using oF0.8.0 on osx 10.9 and haven’t found an easy way to download the 10.6 sdk.

I’ve also tried to set the GstGrabber, but I get linking errors:

  
  
Undefined symbols for architecture i386:  
  "ofGstVideoGrabber::ofGstVideoGrabber()", referenced from:  
      testApp::setup() in testApp.o  
ld: symbol(s) not found for architecture i386  
clang: error: linker command failed with exit code 1 (use -v to see invocation)  
  

however, I thought the dylibs in the GStreamer framework are also usable for i386

  
  
file /Library/Frameworks/GStreamer.framework/Headers /Library/Frameworks/GStreamer.framework/Versions/1.0/lib/libgstbase-1.0.0.dylib   
/Library/Frameworks/GStreamer.framework/Headers:                                 directory  
/Library/Frameworks/GStreamer.framework/Versions/1.0/lib/libgstbase-1.0.0.dylib: Mach-O universal binary with 2 architectures  
/Library/Frameworks/GStreamer.framework/Versions/1.0/lib/libgstbase-1.0.0.dylib (for architecture x86_64):	Mach-O 64-bit dynamically linked shared library x86_64  
/Library/Frameworks/GStreamer.framework/Versions/1.0/lib/libgstbase-1.0.0.dylib (for architecture i386):	Mach-O dynamically linked shared library i386  
  

I’ve tried dragging the framework into the 3rd party frameworks folder and adding the paths to Header Search Paths and Library Search Paths in Xcode but no joy.

I’ve tried using ofQuickTimeGrabber but got a parsing error:

  
  
Unknown type name 'ofQuickTimeGrabber'  
  

After tried ofxUVC which uses ofxQTKitGrabber but ran into errors again:

  
  
Field type 'ofxQTKitVideoGrabber' is an abstract class  
  

Ideally I would like to control resolution (16:9 formats seem a bit deformed/scaled) and autofocus.
Is that possible with my setup (oF0.8.0 on osx 10.9) ? If so, how ?

Thank you