Error... There was a problem generating your project... in Windows

Hmm. I haven’t seen that. It doesn’t really say what went wrong.

My wild guess is something with configuration, such as Windows not thinking you have permission to edit that folder, or something?

Can you build the example projects ok?

This error appears in anything I do in ProjectGenerator
This is the fourth day of my search for the problem, and I don’t know what to do

What IDE are you intending to use? Did you follow all of the steps for installing OF for that IDE, as linked at https://openframeworks.cc/download/ ?

I’m just guessing, since you didn’t mention an IDE, I wonder if maybe you just downloaded OF and tried to run the ProjectGenerator without having set it up with the IDE first. I think ProjectGenerator may need an IDE to set up the project for.

I have vscode 2020, and it’s running on 2017, but it doesn’t make any sense. The project has to be created first, then there will be a problem opening the editor or something similar.

I have not tried to use VS Code before. My understanding is that it is not officially supported by OF, but people have had some success getting it to work, but that it is not something that automatically works. The thread I know about about people working on getting it to work is here: vscode(Visual Studio Code) + oF

I would suggest getting it working in VS 2017 first, since that is supported, starting with making sure I have followed all of the steps for that correctly, as listed here: https://openframeworks.cc/setup/vs/

I’m trying to build the project first and then I come to open it on vscode
Trying to projectGenerator is futile, always get the same error

Right now, I tried latest release version and it is working as expected.
Do you have Visual Studio Community 2017 installed?
If not, PG(Project Generator) might fail.

vs(Visual Studio) project and VSCode project is not compatible.

VSCode project depends on another tools set (msys2, MinGW) and you have to select vscode template on PG. For the details, please read the link @Drazinut suggested above. If you are new to oF, I recommend to start with Visual Studio 2017.

Did you mean this error was due to not installing vscode 2017?
I’ll install it and I’ll tell you in detail

Yes. Again, follow the steps at https://openframeworks.cc/setup/vs/ . Including the part “openFrameworks plugin for Visual Studio
Before you’re able to use openFrameworks with Visual Studio, you have to have Common Tools for Visual C++ 2017 installed, otherwise you’ll get an error message later on.”.