Error running install_dependencies

Dear all,

I get this error when running install_dependencies.sh:

  
victor@victor-laptop2 ~/workspace/of_preRelease_v0061_linux_FAT/scripts/linux/ubuntu $ sudo ./install_dependencies.sh   
Get:1 [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria Release.gpg [198B]  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/main Translation-en_US  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/upstream Translation-en_US  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/import Translation-en_US  
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security Release.gpg  
Ign [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/main Translation-en_US  
Ign [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/restricted Translation-en_US  
Hit [http://archive.canonical.com](http://archive.canonical.com) jaunty Release.gpg  
Ign [http://archive.canonical.com](http://archive.canonical.com) jaunty/partner Translation-en_US  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/community Translation-en_US             
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty Release.gpg                                 
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/main Translation-en_US                      
Get:2 [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria Release [9185B]                       
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/restricted Translation-en_US                
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/universe Translation-en_US                  
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/multiverse Translation-en_US                
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates Release.gpg                         
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/main Translation-en_US              
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/restricted Translation-en_US        
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/universe Translation-en_US          
Ign [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/multiverse Translation-en_US        
Ign [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/universe Translation-en_US        
Ign [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/multiverse Translation-en_US      
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security Release                           
Hit [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty Release.gpg                             
Ign [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty/free Translation-en_US                  
Ign [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty/non-free Translation-en_US              
Ign [http://lgp203.free.fr](http://lgp203.free.fr) Gloria Release.gpg                                     
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty Release                                     
Hit [http://archive.canonical.com](http://archive.canonical.com) jaunty Release                              
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates Release                         
Hit [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty Release                      
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/main Packages  
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/restricted Packages  
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/universe Packages  
Hit [http://security.ubuntu.com](http://security.ubuntu.com) jaunty-security/multiverse Packages  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/main Packages  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/upstream Packages  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/import Packages  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/community Packages  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/main Sources  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/upstream Sources  
Ign [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/import Sources  
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/main Packages                    
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/main Packages                
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/restricted Packages  
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/universe Packages  
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty/multiverse Packages  
Hit [http://archive.canonical.com](http://archive.canonical.com) jaunty/partner Packages                         
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/upstream Packages                       
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/import Packages                        
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/main Packages                       
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/community Packages                      
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/restricted Packages                 
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/universe Packages                   
Hit [http://archive.ubuntu.com](http://archive.ubuntu.com) jaunty-updates/multiverse Packages                 
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/main Sources                            
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/upstream Sources                        
Hit [http://packages.linuxmint.com](http://packages.linuxmint.com) gloria/import Sources                          
Ign [http://lgp203.free.fr](http://lgp203.free.fr) Gloria/universe Translation-en_US                      
Hit [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty/free Packages                           
Hit [http://packages.medibuntu.org](http://packages.medibuntu.org) jaunty/non-free Packages  
Ign [http://lgp203.free.fr](http://lgp203.free.fr) Gloria Release  
Ign [http://lgp203.free.fr](http://lgp203.free.fr) Gloria/universe Packages  
Ign [http://lgp203.free.fr](http://lgp203.free.fr) Gloria/universe Packages  
Err [http://lgp203.free.fr](http://lgp203.free.fr) Gloria/universe Packages  
  404 Not Found  
Fetched 9383B in 1s (6016B/s)  
W: Failed to fetch [http://lgp203.free.fr/ubuntu/dists/Gloria/universe/binary-i386/Packages](http://lgp203.free.fr/ubuntu/dists/Gloria/universe/binary-i386/Packages)  404 Not Found  
  
E: Some index files failed to download, they have been ignored, or old ones used instead.  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
libgstreamer0.10-dev is already the newest version.  
libgstreamer-plugins-base0.10-dev is already the newest version.  
libavcodec-dev is already the newest version.  
libavformat-dev is already the newest version.  
libavutil-dev is already the newest version.  
libswscale-dev is already the newest version.  
freeglut3-dev is already the newest version.  
libasound2-dev is already the newest version.  
libxmu-dev is already the newest version.  
libxxf86vm-dev is already the newest version.  
g++ is already the newest version.  
libgl1-mesa-dev is already the newest version.  
libglu1-mesa-dev is already the newest version.  
libraw1394-dev is already the newest version.  
libudev-dev is already the newest version.  
The following packages were automatically installed and are no longer required:  
  libcaca-dev libaudiofile-dev libaudio-dev libsdl-pango1 libesd0-dev  
  libslang2-dev libncurses5-dev libaa1-dev  
Use 'apt-get autoremove' to remove them.  
0 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.  
echo "compiling objects"  
compiling objects  
echo obj/Debug/../../../openFrameworks/video/ofGstUtils.o | sed "s/obj\\/Debug\\///" | sed "s/\.o/\.cpp/"  
../../../openFrameworks/video/ofGstUtils.cpp  
mkdir -p obj/Debug/../../../openFrameworks/video  
g++ -g -Wall -fexceptions -I../../../FreeImage/include -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../glee/include -I../../../gstappsink/include -I../../../gstappsink/include/gst -I../../../gstappsink/include/gst/app -I../../../poco/include -I../../../poco/include/CppUnit -I../../../poco/include/Poco -I../../../poco/include/Poco/DOM -I../../../poco/include/Poco/Dynamic -I../../../poco/include/Poco/SAX -I../../../poco/include/Poco/XML -I../../../poco/include/Poco/Net -I../../../poco/include/Poco/Util -I../../../rtAudio/include -I../../../unicap/include -I../../../openFrameworks/ -I../../../openFrameworks/video -I../../../openFrameworks/utils -I../../../openFrameworks/app -I../../../openFrameworks/graphics -I../../../openFrameworks/communication -I../../../openFrameworks/sound -I../../../openFrameworks/events `pkg-config  gstreamer-0.10 gstreamer-video-0.10 gstreamer-base-0.10 libudev --cflags`  -MMD -MP -MF `echo obj/Debug/../../../openFrameworks/video/ofGstUtils.o | sed "s/obj\\/Debug\\///" | sed "s/\.o/\.d/"` -o obj/Debug/../../../openFrameworks/video/ofGstUtils.o -c `echo obj/Debug/../../../openFrameworks/video/ofGstUtils.o | sed "s/obj\\/Debug\\///" | sed "s/\.o/\.cpp/"`  
In file included from ../../../openFrameworks/video/ofGstUtils.cpp:3:  
../../../gstappsink/include/gst/app/gstappsink.h:106: error: ISO C++ forbids declaration of ‘GstBufferList’ with no type  
../../../gstappsink/include/gst/app/gstappsink.h:106: error: expected ‘;’ before ‘*’ token  
../../../gstappsink/include/gst/app/gstappsink.h:107: error: ISO C++ forbids declaration of ‘GstBufferList’ with no type  
../../../gstappsink/include/gst/app/gstappsink.h:107: error: expected ‘;’ before ‘*’ token  
../../../gstappsink/include/gst/app/gstappsink.h:131: error: expected constructor, destructor, or type conversion before ‘*’ token  
make: *** [obj/Debug/../../../openFrameworks/video/ofGstUtils.o] Error 1  
there has been a problem compiling Debug OF library  
please report this problem in the forums  
  

I tried reinstalling codeblocks, but something is messed up… I’ve got openFrameWorks working on another machine with the same OS, linux Mint Gloria.

Please help me!
With kind regards,
Victor

this seems to be an ubuntu based distribution right? i

it seems like it’s not able to compile the OF library. you can try to compile it manually, opening the codeblocks project in libs/openFrameworksCompiled/project/linux

but surely you’ll have the same problem. i’ll try to download mint and give it a try.

also you can try to install other libgstreamer*-dev packages to see if that solves the problem

Hello arturo,
Thanks for your reply; I’ll try your suggestion on installing other gstreamer*dev packages. The distribution itself isn’t the problem; on another PC with the same OS it’s working perfectly!

Hello Arturo,
I tried installing other gstreamer packages, but only some haskell extention(?) for gstreamer - dev was not installed yet. Installing it didn’t solve my problem.
After that I tried building the project on the location mentioned in your previous post; had to chown the /obj folder to get write permissions, but after that the build failed:

  
  
-------------- Build: Debug in libopenFrameworks ---------------  
  
Compiling: ../../../openFrameworks/app/ofAppGlutWindow.cpp  
Compiling: ../../../openFrameworks/app/ofAppRunner.cpp  
Compiling: ../../../openFrameworks/communication/ofArduino.cpp  
Compiling: ../../../openFrameworks/communication/ofSerial.cpp  
Compiling: ../../../openFrameworks/graphics/ofBitmapFont.cpp  
Compiling: ../../../openFrameworks/graphics/ofGraphics.cpp  
Compiling: ../../../openFrameworks/graphics/ofImage.cpp  
Compiling: ../../../openFrameworks/graphics/ofTexture.cpp  
Compiling: ../../../openFrameworks/graphics/ofTrueTypeFont.cpp  
Compiling: ../../../openFrameworks/sound/ofSoundPlayer.cpp  
Compiling: ../../../openFrameworks/sound/ofSoundStream.cpp  
Compiling: ../../../openFrameworks/utils/ofMath.cpp  
Compiling: ../../../openFrameworks/utils/ofUtils.cpp  
Compiling: ../../../openFrameworks/video/ofGstUtils.cpp  
/home/victor/workspace/of_preRelease_v0061_linux_FAT/libs/openFrameworks/video/ofGstUtils.cpp: In member function ‘bool ofGstUtils::startPipeline()’:  
/home/victor/workspace/of_preRelease_v0061_linux_FAT/libs/openFrameworks/video/ofGstUtils.cpp:775: error: ‘GstAppSinkCallbacks’ was not declared in this scope  
/home/victor/workspace/of_preRelease_v0061_linux_FAT/libs/openFrameworks/video/ofGstUtils.cpp:775: error: expected `;' before ‘gstCallbacks’  
/home/victor/workspace/of_preRelease_v0061_linux_FAT/libs/openFrameworks/video/ofGstUtils.cpp:776: error: ‘gstCallbacks’ was not declared in this scope  
/home/victor/workspace/of_preRelease_v0061_linux_FAT/libs/openFrameworks/video/ofGstUtils.cpp:780: error: ‘gst_app_sink_set_callbacks’ was not declared in this scope  
Process terminated with status 1 (1 minutes, 39 seconds)  
4 errors, 0 warnings  
   
  

I will try to install the new 0061 release the next time I give it a try, although I might just reinstall the complete system. Immediate time pressure is no longer an issue, and this machine is slooowww…
Thanks for your help so far, if I have updates I’ll keep you informed

Victor

I think I found the problem; on this I found out that

GstBufferList was added to
gstreamer-0.10 in version 0.10.23.3

. I’ll try and install a newer Gstreamer version. This ‘problem’ was introduced in 0.0061

ugh, sorry for that, theres a newer version of gstappsink now, it’s included in the OF package so it works with previous versions but didn’t noticed that it has dependencies with the last gstreamer version.

the thing is this new version of gstappsink is faster than the previous one so things like seek work better than before.

Hello Arturo,

I installed the latest gstreamer from the ppa (had to add it to my sources.list), and now the script runs a lot longer and ends with

  
chown: cannot access `../../lib/linux64/*': No such file or directory  
  

, which I think is OK since this is a 32 bit machine.

I tried to compile a few examples in the 0061 release, and I was able to do some videograbbing, display images, etc. Audio output failed, with this error log from Code::Blocks:

  
||=== audioOutputExample, Debug ===|  
../../../libs/rtAudio/lib/linux/libRtAudio.a(RtAudio.o)||In function `RtAudio::RtAudio(RtAudio::Api)':|  
RtAudio.cpp:(.text+0x119c)||undefined reference to `std::ctype<char>::_M_widen_init() const'|  
||=== Build finished: 1 errors, 0 warnings ===|  
  

it seems thats a bug in certain versions of gcc 4.4.x with compiler optimizations. in debug it should work bu in release for what i’ve found googling it seems it can be solved by using a compiler flag:

go to project > project options > project build properties

select Release in the left part of the window, and the other options tab. there enter:

-fno-inline

Hello Arturo,
My gcc version is 4.3.3, and even if I add the -fno-inline option I still get the same error. The 006 version compiles fine. I copied the RtAudio and AudioExample directories out of the zip on the website to be completely up to date, but to no avail.
I found this site where somebody mentions it might be libstdc++ being out of date. I’m using libstdc++6-4.3-dev version 4.3.3-5ubuntu4.