Error on Qt, Fedora 33: "The following products could not be built for configuration qtc_Desktop_Debug:"

Hi there,

I still have some errors.

Ok. So I had figured some things out.

To fix the error I previously had.

Refer to this post:

Downloading the nightly version of OpenFrameworks fixed it. “of_v20210207_linux64gcc6_nightly.tar.gz”. And it works fine.

I then proceeded to use the OpenFrameworks projectGenerator GUI and added the add-ons to use for my Twitter project.

Next, I opened it using Qt, and tried to run the program. Unfortunately, I cannot run any openFrameworks programs anymore on Qt. I tried to install another version but it still does not work.

Here is a screenshot:

Why is this happening? Can it be fixed? Any help is appreciated.

T0mR

Hi @T0mR

I just tried using the qtCreator on mac with the linux templates and a 3rd party addon:

It generated a project file which I could open with QT Creator 4.10.2.

From my understanding if the addon is in the OF_ROOT/addons folder all you need to do to add it to an existing working project is add it to this line of the ofApp.qbs:

A couple of things to try:

  • Do the examples that come with the nightly release work for you?
  • Does the PG making a project without any addons work for you?
  • If it is just the projects with 3rd party addons not working, can you try not adding the addons via the PG but after you open the project add the addons in the qbs file like above?

For any errors that you get like the one you showed in your post could you expand the myApp/ folder and open the ofApp.qbs and see what errors it lists in the qbs file?

Thanks!
Theo

Hi theo,

Thank you for your reply.

As you have described I tried to add the add-ons onto the ‘.qbs’ file directly. There were a couple of issues.

In the first scenario of adding them directly, the whole project would not update (add them) with the add-ons. Even though I had press ‘Crl + S’.

The second event, would be to check one of the boxes while creating the project (adding core add-ons). This actually added the add-on in the project, and I was able to add more with the same method above. However, I would still get an error.

When I tried it, the nightly release did not work for me with Qt. This time I would get a different error. It would not build. Even though the add-ons were recognised and there.

Unfortunately, I had to remove Linux from my system, and to install Windows 10 for my project. I have setup it in dual-boot which is better in case I have to revert to Windows 10. I had other errors with Windows 10 and Visual Studio. With the stable build and the add-ons it seems to have errors. It can become a little tricky. But I managed to find the prepacked version with the add-ons I had used more than a year ago.

Once I advance with the project, I can show the errors I have, and maybe put an issue request on Git.

Thanks for all your help, theo and especially your time.

T0mR

Hey, no problem!

Sorry you didn’t get it working.
One thing I found with QTCreator is I had to do a clean from the build menu to get changes to show up.

If you end up trying again it is definitely post the details of the errors either here or on Github.

When I can get my Linux machine booted up I will try it out and see if I can reproduce the issues you were having.

Good luck with your project!
Theo