Error on compiling ofxFern probably OpenCV related

Hi all,

I tried to compile danomatika’s branch of ofxFern. However, I’m stuck at linking error which produced this message:

Undefined symbols for architecture i386:
“_cvSaveImage”, referenced from

I thought that it was OpenCV related, however, I can compile ofxCv with no errors. I realized that this addon is pretty old now, is there any issue with my system which uses ofx 0.8 and XCode 4.6.3? I’m on OS X 10.9.1 btw…

Should I just generate new Xcode project then? Assuming that my OpenCV is working fine…

Any idea how to solve this? Cheers :smiley:

This feels like the library and its dependencies were built against an older version of opencv. I’d check if you can get an updated source code for everything in this folder: https://github.com/danomatika/ofxFern/tree/master/src/ferns

[EDIT]
Maybe @paulobarcelos has addressed the issue with this commit in his branch: https://github.com/paulobarcelos/ofxFern/commit/33650e65fd628508573593f523ba2c6dfade0a03

wow, I tried compiling from @paulobarcelos branch and it actually works. thanks a lot for pointing it :smiley:

on the other hand, is initiating multi ferns possible? I’m trying to detect 3 different pictures at the same time. or is there any other way to accomplish so?