Error: missing target product

Hi,

I keep getting this error message when executing a simple nested for Loop:

:-1: Unable to resolve build file: XCBCore.BuildFile (missingTargetProductReference(“fb811e3ddac979b544d01e4f7d1ba3984ffa05ab947bba0566490cb944358c75”)) (in target ‘Shapes From Pixels’)

Here is the code:

//--------------------------------------------------------------
void ofApp::setup(){
ofBackground(255);
ofSetFrameRate(60);
vidGrabber.setDeviceID(0);
vidGrabber.setDesiredFrameRate(30);
vidGrabber.initGrabber(ofGetWidth(), ofGetHeight());
startPos = spacing/2;
spacing = 10;

}

//--------------------------------------------------------------
void ofApp::update(){
vidGrabber.update();
pixels = vidGrabber.getPixels();

}

//--------------------------------------------------------------
void ofApp::draw(){

for (int i=0; i<ofGetWidth(); i+=spacing){
    for (int j=0; j<ofGetHeight(); j+=spacing){
        int locX = startPos + i;
        int locY = startPos + j;
    
    ofSetColor(0);
    ofDrawCircle(locX, locY, 3);
    }
}

}

can you provide more info about what ide you are using (from the error code I assume it is Xcode, but which version), the OS version and the OF version you are using.
Try cleaning your xcode project. In the Product menu choose clean. Also do the same but while holding the alt key and clean will change to “clean build folder”.

This was happening with Xcode 10 when you have 2 OF projects open. Not sure if the latest patch release solves this (kinda doubt it)

Sorry didn’t realize this was a build error. But good to initialize the variable too! :slight_smile:

Is this with the latest 0.10.1 release?

I have Xcode 10.0; Mac OS 10.13.6.; OF 10.0. I have tried it with only one Xcode window open and it still says Build Failed.

I see. Is this happening with the examples as well? or just with the code you posted ?
On Xcode’s right pane on the errors list, right clic on the error and select reveal in log. Copy and paste there the whole log please.

@jvcleave I think as of 0.10.1 you should be able to have two examples or more open - as we are not including the OF project in the example projects anymore.

@haberdasher - please try 0.10.1 - https://openframeworks.cc/versions/v0.10.1/of_v0.10.1_osx_release.zip
0.10.0 has numerous problems with Xcode 10.0

thank you i will

Ah interesting!

I got this error after updating macOS (which requires an update to Xcode and command line tools) … this fixed it for me (restart Xcode after changing the setting).