Error installing latest update of VS2017 plugin

Update log says

The prerequisite version specified does not match the version installed

Microsoft forums says this is the solution;

https://marketplace.visualstudio.com/items?itemName=vs-publisher-356819.MicrosoftAspNetTemplates#qna

hi @donovan-digital do you have more information about the error?

I tested in my environment, here is my VS about

Did you replicate the error, or not? Would you like me to post the same info you posted?

I was not able to reproduce your error. The link you mentioned (AspNet…) looks not related to C++ projects, was there any other information in the Microsoft forums ?

I can not even install it. According to the installation log(Japanese), it is indicated that the version is different.The version required by Openframeworks is 15.0, and the latest VS2017 seems to be 15.6.


2019/02/19 9:48:32 - Skipping ‘C:\Users\tauchi\AppData\Local\Microsoft SDKs’ as it doesn’t exist
2019/02/19 9:48:32 - ID ‘VSIXopenframeworks2017.A049B6B4-2855-4C1C-A3A6-13ED823BB898’ の拡張機能は Microsoft Visual Studio Community 2017 にインストールされません。
2019/02/19 9:48:37 - 前提条件が不足しているため、次の製品に拡張機能をインストールできません:
2019/02/19 9:48:37 - Microsoft Visual Studio Community 2017
2019/02/19 9:48:37 - -------------------------------------------------------
2019/02/19 9:48:37 - Identifier : Microsoft.VisualStudio.Component.CoreEditor
2019/02/19 9:48:37 - Name : Visual Studio core editor
2019/02/19 9:48:37 - Version : [15.6]
2019/02/19 9:48:37 - Error : 指定した必須コンポーネントのバージョンが、インストールされているバージョンと一致しません
2019/02/19 9:48:37 -
2019/02/19 9:48:37 - System.InvalidOperationException: 変更を適用できませんでした。

installation failed . the installation log

2019/2/19 14:58:33 - ID 为“VSIXopenframeworks2017.A049B6B4-2855-4C1C-A3A6-13ED823BB898”的扩展未安装到 Microsoft Visual Studio Community 2017。
2019/2/19 14:58:37 - 由于缺少系统必备组件,因此无法将扩展安装到以下产品:
2019/2/19 14:58:37 - Microsoft Visual Studio Community 2017
2019/2/19 14:58:37 - -------------------------------------------------------
2019/2/19 14:58:37 - Identifier : Microsoft.VisualStudio.Component.CoreEditor
2019/2/19 14:58:37 - Name : Visual Studio core editor
2019/2/19 14:58:37 - Version : [15.6]
2019/2/19 14:58:37 - Error : 指定的系统必备组件版本不匹配已安装的版本
2019/2/19 14:58:37 -
2019/2/19 14:58:37 - System.InvalidOperationException: 无法应用修改。

Same problem here with a fresh install of VS2017. Seems it referring to some 15.6 version of the editor?

Same issue here trying to install the plugin via Extension Manager in VS2017

19/02/2019 01:00:51 PM - The extension with ID 'VSIXopenframeworks2017.A049B6B4-2855-4C1C-A3A6-13ED823BB898' is not installed to Microsoft Visual Studio Community 2017.
19/02/2019 01:00:55 PM - Extension cannot be installed to the following products due to missing prerequisites:
19/02/2019 01:00:55 PM - 	Microsoft Visual Studio Community 2017
19/02/2019 01:00:55 PM - 		-------------------------------------------------------
19/02/2019 01:00:55 PM - 		Identifier   : Microsoft.VisualStudio.Component.CoreEditor
19/02/2019 01:00:55 PM - 		Name         : Visual Studio core editor
19/02/2019 01:00:55 PM - 		Version      : [15.6]
19/02/2019 01:00:55 PM - 		Error        : The prerequisite version specified does not match the version installed
19/02/2019 01:00:55 PM - 
19/02/2019 01:00:55 PM - System.InvalidOperationException: No modifications could be applied.

I have exactly the same problem:

openFrameworks plugin for Visual Studio 2017
This extension contains prerequisites that could not be found

hi @oxist @PresidentDoggo @sphaero @qiyeyihao I’m testing it in an isolated virtual machine, I hope to sort it out today!

It should be fixed in the new release 0.7 from the marketplace: https://marketplace.visualstudio.com/items?itemName=HalfA.openFrameworkspluginforVisualStudio2017

You can also install/update from Visual Studio.

Thank you very much @haschdl !

Hi, I am also having this issue, even when I used the new release from the marketplace.
Is there anything I could do?
thanks

Updated the version (15.9) and its working now.
thanks