Error compiling using latest XCode 4.0

I have just installed the latest XCode 4.0 and tried to compile the iphoneTouchAndAccelExample but I get the following error:

Library not found for -lgcc_s.10.5
Command /Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/g+±4.2 failed with exit code 1

Does anyone knows what this is all about?

Thanks

Baldo

Based on googling, it looks like something for OS X. If this is an existing project from Xcode 3 then it should already be pointing to iOS but, if you started new it might default to OS X. Just a thought… I’d be happy to research further (later) if this doesn’t solve your issue.

Turns out that the project has os x 10.5 as the mac os x deployment target so I changed it to mac os x 10.6 and it worked.

Thanks for the solution.