Error compiling under Precise " undefined reference to 'dlsym' "

Hi everyone,

I’ve had trouble running the script ./install_dependencies.sh on my Ubuntu Precise installation:

  
  
../../../libs/fmodex/lib/linux/libfmodex.so: error: undefined reference to 'dlsym'  
../../../libs/fmodex/lib/linux/libfmodex.so: error: undefined reference to 'dlopen'  
../../../libs/fmodex/lib/linux/libfmodex.so: error: undefined reference to 'dlclose'  
collect2: ld returned 1 exit status  
make: *** [bin/projectGeneratorSimple] Error 1  
there has been a problem compiling the projectGenerator  
  

The problem seems to happen while linking the projectGenerator and could be easily solved in my case by doing the following:

  • cd …/…/…/apps/projectGenerator/projectGeneratorSimple
  • vi config.make
  • Line 20, USER_LDFLAGS = -ldl
  • save the file
  • run install_dependencies.sh again

Hope it can be useful to anyone having the same problem!

I can’t reproduce this with my quantal install and current develop branch. would you be so kind to report this at https://github.com/openframeworks/openFrameworks/issues, with some more details about your setup (e.g. where you got OF from and which version it is) and a link to this thread?

hello adupuis :

i am using ubuntu 12.10 and i had the EXACTLY same issue, SOLVED with your suggestion. So i greatly appreciate you post this, because i find it very useful!!!

greatly thanks !!!

regards,

daniel

adupus

It worked for me on Oneiric. Thank you :slight_smile: