Emscripten / Mac OSX 10.11.6 / OF 0.9.8 <Can't Run>


#1

Tried to run emscripten for the first time and got thrown these errors. Help?


#2

this is a known problem with the current release version, it seems that the last emscripten is not compatible with the compiled libraries that come with 0.9.8 or earlier anymore. you can try using an older version of emscripten or using the OF nightly builds


#3

oh thanks for the info. i’ll wait for it be back in the stable release, was just trying it out out of curiosity :slight_smile:


#4

Did you ever get emscipten to work?
I have it instaled according to the instructions, but cant’ even get the ‘emmake make’ command to run
( ‘command not found’) even though PATH is setup correctly via the shell script.


#5

didn’t try after @arturo mentioned that there are issues with the current version - but the emmake make command was working for me though.


#6

hey @steeley
maybe you can try to redo this:

Fetch the latest registry of available tools.

./emsdk update

Download and install the latest SDK tools.

./emsdk install latest

Make the “latest” SDK “active”

./emsdk activate latest

or just this:

the installation will take a while. When it is finished, type source ./emsdk_env.sh to set the system path to the active version of Emscripten. You can copy the output of this command and add it to your .profile file, in order to save this variables also for the next sessions.

when I open another terminal window emmake didn’t worked neither. Only on the same terminal window I run this previous commands before. It seems related to the path where the emmake command is for the system.

btw, i tried to build with the OF master branch and I am getting errors too:
> …he/asmjs/libcxx_noexcept.a! Error:dyld: lazy symbol binding failed: Symbol not found: _futimens

      Referenced from: /Users/m/Downloads/emsdk-portable/clang/e1.37.27_64bit/llvm-ar (which was built for Mac OS X 10.13)
      Expected in: /usr/lib/libSystem.B.dylib
    dyld: Symbol not found: _futimens
      Referenced from: /Users/m/Downloads/emsdk-portable/clang/e1.37.27_64bit/llvm-ar (which was built for Mac OS X 10.13)
      Expected in: /usr/lib/libSystem.B.dylib
    0  llvm-ar                  0x00000001030b5d88 llvm::sys::PrintStackTrace(llvm::raw_ostream&) + 40
    1  llvm-ar                  0x00000001030b6336 SignalHandler(int) + 358
    2  libsystem_platform.dylib 0x00007fff93bedb3a _sigtramp + 26
    3  libsystem_platform.dylib 0x000000010656fb4d _sigtramp + 1922572333
    4  libsystem_platform.dylib 0x000000010657a464 _sigtramp + 1922615620
    5  libsystem_platform.dylib 0x0000000106555793 _sigtramp + 1922464883
    6  libsystem_platform.dylib 0x000000010655589e _sigtramp + 1922465150
    7  libdyld.dylib            0x00007fff939da282 dyld_stub_binder + 282
    8  llvm-ar                  0x00000001032ec340 (anonymous namespace)::DarwinX86AsmBackend::getCompactUnwindRegNum(unsigned int) const::CU64BitRegs + 10650
    9  llvm-ar                  0x0000000102f7de6d performOperation(ArchiveOperation, llvm::object::Archive*, std::__1::unique_ptr<llvm::MemoryBuffer, std::__1::default_delete<llvm::MemoryBuffer> >, std::__1::vector<llvm::NewArchiveMember, std::__1::allocator<llvm::NewArchiveMember> >*) + 2013
    10 llvm-ar                  0x0000000102f7d0a2 performOperation(ArchiveOperation, std::__1::vector<llvm::NewArchiveMember, std::__1::allocator<llvm::NewArchiveMember> >*) + 930
    11 llvm-ar                  0x0000000102f7ac99 main + 361
    12 libdyld.dylib            0x00007fff939de235 start + 1
    13 libdyld.dylib            0x0000000000000003 start + 1818369487
    Stack dump:....

#7

Thanks will have a look at this.


#8

Add emmake to PATH in .bash_profile

export PATH="$PATH:/Your/Path/To/emsdk/emscripten/1.38.0"