Emscripten /linux / OF 0.9.0

hi,

Thanks for the new released:)
the problem is that i not able to set the Emscripten in the path enviroment.
I compiled it and run the comands inside the Emscripten directory all go.
When i do the command in one of the ofExample or in other place i have the error

bash: emmake make : command not found

how is possibile to set it:?

thanks

yea, i solved it.
i put the right path with the comand

source "mypath"/emsdk_env.sh

now i have a second problem :), when i compiled the ofexample i have this error:

  'cairo-features.h' file not found

I have not yet installed any IDE, and i have not compiled OF 0.9.0 white the IDE. Maybe it is the problem.?

i have compiled OF, and if i do the comand make, make run i can compile the example with out problem.
But when i do the comand emmake make, i have the same error
cairo-features.h not found

there was a problem with emscripten in the linux downloads, if you download it again it should be fixed now

Emscripten or oF is to download again?

anyway i solved it in brtual mode

copy files
from usr/include/cairo to /of_v0.9.0_linux64_release/libs/openFrameworks/graphics

and all it go :slight_smile:

i meant openframeworks but great you solved it

hey guys can you be more specific on the “my path” thing?

I tried:

a@a-desktop:~/Downloads/emsdk_portable$ source ~/Downloads/emsdk_portable/emsdk_env.sh
Adding directories to PATH:
PATH += /home/a/Downloads/emsdk_portable
PATH += /home/a/Downloads/emsdk_portable/clang/fastcomp/build_master_64/bin
PATH += /home/a/Downloads/emsdk_portable/node/4.1.1_64bit/bin
PATH += /home/a/Downloads/emsdk_portable/emscripten/master

Setting environment variables:
EM_CONFIG = /home/a/.emscripten
EMSCRIPTEN = /home/a/Downloads/emsdk_portable/emscripten/master

a@a-desktop:~/Downloads/emsdk_portable$

**

but I still get:

**

a@a-desktop:~/Downloads/of_v0.9.2_linux64_release/examples/video/videoPlayerExample$ emmake make
The program ‘emmake’ is currently not installed. You can install it by typing:
sudo apt-get install emscripten
a@a-desktop:~/Downloads/of_v0.9.2_linux64_release/examples/video/videoPlayerExample$

also… regarding editing .profile I assume is the one in etc/ right?
can you be more specific on the syntax like post an example?

:beer:

you have to do that from the same terminal you are running emmake.

also it’s .profile in your home folder not in etc, the one in etc would work to but better to do it only for your user

ah I see, thank you it worked…
sort of…



what do you think about these errors? what is the .data file?

not sure why this is happening, i’ve seen it lately and it seems to be related to firefox having trouble with webgl sometimes. try using chromium, that solves it for me, i’ll try to check why this is failing in firefox

doubt it’s a firefox thing because I can play the examples at your blog with no problem whatsoever.
Nevertheless I tried with chrome but I am afraid it doesn’t work either.

it keeps loading and when I toggled fullscreen the entire operating system hanged/crashed and I had to force-quit.

I also tried empty example, blending and a couple of more but always got the same results

I was thinking
maybe I don’t have my graphics card installed properly I only did vanilla installation of ubuntu 15 .

but if it was my graphics card I wouldn’t be able to compile examples normally right?
thus far I didn’t have any other problems with compiling examples in ubuntu (not emscripten i mean)

you should use emrun to run the examples it wont’ work just by opening the file in chrome like you seem to be doung there

ah I see…

regarding the toggle full screen thing It seems that it happens outside emscripten as well, I tried the 3d primitives examples and when I pressed “f” whole system crashed again. I will try on my other ubuntu machine and let you know if it is reproducible

hm… weird… very weird… so… I tried the examples from your site again on the problematic machine (with i7 and a quite good graphics card ) after installing emscripten and nothing worked anymore on firefox and in chrome the fullscreen crash repeated every time.

(i had to use REISUB to kill the computer)

Now on machine B with ubuntu 15 with the following miserable specs

everything works fine BOTH on firefox and Chrome!!

no fullscreen crash whatsoever. //edit untill I left the 3d view example open on firefox for a few minutes and the cursor disappeared for good …

anyhow…

Do you think is possible emscripten installation to have broken anything?
I remember firefox to work before I installed emscripten!

I really hate to reinstall ubuntu on the problematic machine… It’s a pain to set-up shared folders with correct permissions so that I cross compile :expressionless:

i think it’s just some bug in latest versions of firefox or ubuntu i’ve seen the crashes when going full screen too recently and i hadn’t used emscripten for a while

1 Like