emptyExample fails to compile in OF v0062

Hi guys,

I’ve been comfortably running OF v0061 on My MacBook Pro using Xcode v3.2.3 for quite some time now.

I’ve recently needed to set up OF v0062 for a project and find that I’m running into a lot of errors simply opening and running the emptyExample project.

I’ve also tried running running the latest OF off of Github and have run into similar errors.

links to screenshots:

Has anyone else noticed an issue?



I just grabbed everything fresh from git and works fine for me w/XCode 3.2.3.

Can you build the OF project itself (you can find it in the emptyExamples/openframeworks)? Also, make sure that the libs/core/core frameworks are all actually in the right places (though I’m not sure how your system would have these in different places).

Hi Josh,

I tried building the OF project itself and ran into the same issues. Also checked that the frameworks existed in libs/core/core. It’s strange that v0061 works with no issues. Hmmm.


i more or less had the same errors when i changed to 0062 and i fixed it by changing the base sdk. try going to project->edit project settings->base sdk for all configurations-> Mac OS X 10.5 or 10.6.

This had no impact for me here, though in the past I’ve done something similar to get v0061 working

If right-click on one of the frameworks and hit “show in finder” does it direct you anywhere? I don’t think you can add them w/o them existing, but it might at least eliminate one option. Are you using the version out of git? If so, when you run a git log you see something like this?

[base-2:emptyExample]base$git log emptyExample.xcodeproj  
commit 36765715e298f1d3ee3cc8f4b01853819e055d58  
Author: ofTheo <theo@openframeworks.cc>  
Date:   Mon Nov 8 11:35:30 2010 -0500  
    set sdk to Current OS for all xcode projects. Closes #241  

Right-clicking in the frameworks and revealing in finder shows the file at the following path:


I am running the git version downloaded here: https://github.com/openframeworks/openFrameworks

I also run into the same kind of errors if I run v0062.

How would I run a git log? Is that something I can do from the actual git project or do I need to download it first?


Thank you everyone for your suggestions. I still haven’t solved the issue, but maybe I’m getting closer (?).

Here are some other things that I tried to solve the problem:

  • Moving the OpenFrameworks folder outside of the Applications folder. v0061 is currently in there and runs just fine. I moved the latest git version to the Desktop and then to the main internal hard-drive and tried to compiled the emptyExample from within, but had the same errors.

  • Someone had suggested that problems can sometimes arise when there are multiple users on the machine in which OF is installed. I only have one user on my laptop, so I don’t think this could be the issue.

  • Someone suggested that I make sure the path had no appending or prepending spaces in it. I didn’t find any spaces. I went ahead and closed the gap between “Macintosh HD” just in case, but the same errors ensued.

  • Another person suggested that the errors I was getting related to OpenGL, and suggested that I make sure that library was intact and not red, but it appears to be fine.

  • Someone suggested that the zip fie that I downloaded OF from Git with might have been corrupted. I went and downloaded the tar.gz file just in case. Same errors.

  • Finally I checked the Project Settings for v0061 (which works fine), and made sure the settings in v0062 matched.

A couple other things I’m going to try:

  • Update Xcode to a later version. I’m currently using 3.2.3. I’ve talked to two people running Macbook Pros, who have said they were able to run the current OF off of git with Xcode 3.2.3 and had no problems.

  • Archive install and perhaps a clean install of OSX (would like to avoid this at all cost!)

Lastly, here are some more expanded shots containing the errors that I’ve been getting:


Ok, I’ve now upgraded Xcode from 3.2.3 to 3.2.5, and I’m getting only 59 errors, when I run emptyExample off of the latest OF git.


And when I run it under OF v0062, no errors :slight_smile:

I will try to make things work under v0062