Eclipse setting and compiling error

When I run basic example on OF for android, this error message comes out

Program “/toolchains/arm-linux-androideabi-4.9/prebuilt/linux-x86_64/bin/arm-linux-androideabi-g++” not found in PATH
(Resource: androidEmptyExample)

This was happened when androidEmptyExample run.
My Eclipse version is 4.5.2 and OF is 0.9.3

What should I fix?
(Actually I tried to set Android Studio also and asked about it on this fourm also, but now I have less errors on Eclipse) :hushed:

Thank you-

Did you edit this file? :


for “NDK_ROOT” ?? Yes I did.

And I also setting location for NDK in Eclipse preference.


Can you try to add arm-linux-androideabi-g++ path into your system path?
(If you are on Linux, it is /etc/environment)

It’s still not working…

Add file path to my system path is this way:


both are not working.

Is it wrong way?(I’m on Mac 10.11.4)

(I could find there are some similar issues on this forum but no appropriate solution here…)

Oh, do you use Mac? It looks here for the linux version:

Oh… that’s right… That path seems for linux version.
The different thing for my path is there is no folder named “darwin-x86_64”, instead linux-x86_64.

Why Eclipse finds linux version even I’m on mac?

What shoud I do?
Do I have to change my folder name it(darwin-x86_64) to linux version(lunux-x86_64)?

There was similar issue on linux system in this forum. Does that can be solution?

Oh!! I find person had exactly same issue!!

Perhaps I can find soultion.

Thank you very much @Rancs.

For the record, I’m in Linux (Ubuntu 16.04), I had the same issue and added the NDKPATH/toolchains/arm-linux-androideabi-4.9/prebuilt/linux-x86_64/bin path to /etc/environment as @Rancs suggested, restarted Eclipse, and the error went away!