Eclipse openframework plugin not working ubuntu

I am trying to use eclipse for openframework development I fallow this video https://vimeo.com/143111040 but unfortunately I cannot install openframework pugins for eclipse. I get error like this.

I decided to use eclipse because I failed to install qt on ubuntu I dont know which qt version is best for ubuntu.

eclipse is not supported anymore. in ubuntu as well as in any other OS the recommended version for qt is 4.6.1

Hello now I am using latest version of openframework and I use qt 4.6.1 on ubuntu… I setup it on ubuntu server (Azure) but it doest not work because of GLX extension not found error how to fixed this? I am using tightvnc to access the server to setup openframework and qt. any idea?