Download for RPi Broken?


#1

Hey everyone!

Just starting out the OpenFrameworks and Raspberry Pi. I am following the Getting your Raspberry Pi Ready for Openframeworks document however I am running into a problem when trying to uncompress the ARM v6l release. When I download and unzip for linux armv6 with:

1. cd
2. curl -O http://www.openframeworks.cc/versions/v0.8.4/of_v0.8.4_linuxarmv6l_release.tar.gz
3. mkdir openFrameworks
4. tar vxfz of_v0.8.4_linuxarmv6l_release.tar.gz -C openFrameworks --strip-components 1

I get the error

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: existing now

I checked the file type that was downloaded and the console showed that the file was an HTML document - not a compressed gzip.

I have tried two other methods of downloading/unzipping the file but neither were a success:

  1. Unzipped with ‘vxf’ instead of ‘vxfz’
  2. Downloaded with ‘wget http://www.openframeworks.cc/versions/v0.8.4/of_v0.8.4_linuxarmv6l_release.tar.gz

I can found a work around for this (via SSH) but was curious if anyone has come across the same problem or if I am missing something here.


#2

not sure but just tried it here and it is working ok


#3

Dumb answer, but:
I thought this was linuxarmv6**1** for a long time, but it’s linuxarmv6**l**, small letter L. Possible that there’s a secret typo?