Demos build and run, nothing else does!

Apologies - this is bound to be user error as I’ve only just installed Xcode tonight for the first time. I thought I was pretty hot for knowing Processing; now I am humble once again :wink:

Thanks!

did you drag all of the source code into the xcode project ? do you have files like testApp.cpp duplicated twice?

we’d need to see the errors or a zip of the project to diagnose.

take care,
zach

Yes, I dragged the files into /src, and I can’t see any duplicates.

I’ve been trying to play with a project called AWholeLotOfBalls (source code here: http://code.google.com/p/ruisource/downloads/list)
The filename indicates it was written for OF v0.05, so after v0.06 I tried using that but it throws up 153 errors :oops:

Thanks for your help, I really do appreciate it!

there are quite a lot of files in the src folder for that example.

did you bring them into your xcode sketch. unlike the processing, xcode (and other IDEs) don’t compile everything that’s in a folder, just what you tell them to. So, for example, if the last project ust cared about testApp.h, testApp.cpp and main.cpp then you aren’t compiling the other files that come with this project, thus your errors.

on xcode, you can simply drag and drop (be careful not to drag in testApp twice however). On CB/VS you have to go to project → add files in the menu.

hope that helps!
zach

Yes, all those files are now listed in my Xcode project. I dragged them in.

If the problem is that Xcode isn’t compiling certain parts of the project, then how do I tell it to do that?
I started with “emptyProject” and simply added files - is that not the correct procedure?

Thanks again for your help.

ok this project uses the vector math addon, so you’ll need to copy the “vectorMath” example from the addonsExamples not the emptyExample.

then, you’ll need to alter #include “ofAddons.h” to #include “ofxVectorMath.h” since the addons inclusion process changed in 0.06.

you didn’t pick the easiest code to try first ! good luck

take care,
zach

Thanks Zach! That’s helped me quite a bit. From 152 errors down to just 5 now :mrgreen:

So, too many arguments? it looks fine to me - but then I’m just counting to 3.
The custom shell script I can’t make any sense of. I tried manually placing libfmodex.dylib in the target directory, but this throws up another error.

Sorry to keep coming back with more questions. I’ve locked my teeth into it now!

try solving the circle thing first, I don’t know if the other error will be there.

there is no 3d circle command, so make it 2d for now – i’m not sure who wrote this code, but we only have

  
ofCircle(x,y,radius)   

not

  
ofCircle(x,y,z,radius)  

you can do the z, by:

  
ofPushMatrix();  
ofTranslate(0,0,z);  
ofCircle(x,y,radius);  
ofPopMatrix();  
  

does that help?

take care,
zach

Hmm, should I not just be defining “z”? This doesn’t fix it but seemed logical to me.

  
void ofCircle(float x,float y, [b]float z[/b], float radius);   
// [b] for emphasis on this forum post  

From looking at the rest of the code, such as:

  
  
void Particles::render(){  
	float scale =  (float)life/iniLife;  
	ofSetColor(color[0],color[1], color[2]);  
	ofCircle(pos.x, pos.y, [b]pos.z[/b], size*scale);  
	  
	#ifdef ShowTrail  
	ofSetColor(color[0],color[1], color[2], 40);  
	  
	renderTrail();  
	#endif  
	  
}  

I don’t know where you found that code, but ofCircle only works with x,y,radius. you can’t add a z value there (maybe whoever wrote that code can explain more, they may have modified openframeworks or something else). As this isn’t my code, i can’t explain why it’s written like that, but it’s not correct.

In order to get the current code to compile, you are going to have to change it.

Therefore, If you want to draw the circle with a z value, follow the steps described above…

take care,
zach

Taking out all references to pos.z worked! :slight_smile:
Thanks for all your help, really appreciate it.