Current OF release and fresh Ubuntu

I wanted to setup a linux machine with OF and the current release (download not from git). I ran into a few issues and still don’t get everything going. First I am running Ubuntu GNOME 16.04.4 LTS

First, the install_dependencies script, it was breaking on installing libgl1-mesa, so I removed
from the script in an effort to get things moving and it seems most things are OK, not sure what this does exactly, maybe someone can let me know what it might break.

Next I went to setup qtcreator. throws an error
./ 8: ./ Bad substitution
I found some references close to this:

But the first solution is now part of the script and the second: removing, ~/.config/QtProject does not help.
So, I check the script and manually copied the two folders into the templates/wizards directory.

At this point none of the qbs files in the download work in qtcreator (not sure why, I am not familiar with it), but with the new project function I now have access to the openframeworks wizard and can update projects. The updated projects open, but do not compile (I am updating the examples that come with the download)
When I try to build I get
:-1: error: The following products could not be built for configuration qtc_Desktop_Debug:
And I get a similar issue in release (I am using qtcreator 4.6.1).

The download has a project generator compiled, but this does not function either, it reports (for generating a new project or updating an old)

Command failed: /bin/sh -c "projectGenerator"  -o"/home/fred/Documents/of_v0.10.0_linux64gcc6_release" -a" " -p"linux64" "/home/fred/Documents/of_v0.10.0_linux64gcc6_release/apps/myApps/mySketch"
/bin/sh: 1: projectGenerator: not found

I tried to compile the project generator from the script but this just gives me the folder and no app (I am guessing I need the git download and PG repository to do this).

I have run update and upgrade on every step, and have a very minimal install (gfx driver, wifi driver and of stuff). I would love to get going with QTcreator if anyone can help me out or explain the errors.



1 Like

And I solved most of this updating to ubuntu 18.04. I am guessing because gcc shipped with 16.04 is 5.4, but I thought that running update would update gcc, I guess not.

I still have a problem with the project generator not working and none of the qbs files work out of the box, but I can compile now if I update the projects. Almost there.