Cults & Daggers - released on Steam

Just a quick thank you to the OpenFrameworks community. My game Cults & Daggers using OF was released on Steam last week. I think this is the second after Super Hexagon?

For future developers considering this the only OF issue I have had is around graphics cards. Starting in windowed mode is best to avoid some blank screen problems in fullscreen mode and some (~1%) of PC laptop graphics cards simply crash on boot up. I am trying to recompile in an older version of OF which hopefully will help address the problem.

Anyway OF can work for commercial games! Cheers!

Rod

1 Like

before trying to go back to an older version i would just try by using an ofAppGlutWindow instead of GLFW. congrats!

Thanks, Yeah I already tried this…

#include "testApp.h" #include "ofAppGlutWindow.h"

int main(){
ofAppGlutWindow window; // create a window
// set width, height, mode (OF_WINDOW or OF_FULLSCREEN)
ofSetupOpenGL(&window, 1024,768, OF_WINDOW);
ofRunApp(new testApp()); // start the app
}

sadly it did not help those impacted customers. My other issue with going back to an older version is I rely on bundled add-on ofxml so I will have to figure out how to get that retrofitted or change my save game stuff.

Thanks for the suggestion though, any help appreciated!

do you have a stack trace from any of the crashes?

Hey thanks! None from customers. I now have a test machine here that crashes. This is the output after I open the executable with WinDbg (doesn’t seem very helpful). If there is a way for me to get you better data I am more than willing to do so, please let me know. Your help is deeply appreciated!


Microsoft ® Windows Debugger Version 6.12.0002.633 X86
Copyright © Microsoft Corporation. All rights reserved.

CommandLine: “C:\Documents and Settings\max\Desktop\bin\cnd.exe”
Symbol search path is: *** Invalid ***


  • Symbol loading may be unreliable without a symbol search path. *
  • Use .symfix to have the debugger choose a symbol path. *
  • After setting your symbol path, use .reload to refresh symbol locations. *

Executable search path is:
ModLoad: 00400000 00c09000 image00400000
ModLoad: 7c900000 7c9b2000 ntdll.dll
ModLoad: 7c800000 7c8f6000 C:\WINDOWS\system32\kernel32.dll
ModLoad: 10000000 10046000 C:\WINDOWS\system32\guard32.dll
ModLoad: 7e410000 7e4a1000 C:\WINDOWS\system32\USER32.dll
ModLoad: 77f10000 77f59000 C:\WINDOWS\system32\GDI32.dll
ModLoad: 77dd0000 77e6b000 C:\WINDOWS\system32\ADVAPI32.dll
ModLoad: 77e70000 77f03000 C:\WINDOWS\system32\RPCRT4.dll
ModLoad: 77fe0000 77ff1000 C:\WINDOWS\system32\Secur32.dll
ModLoad: 77c00000 77c08000 C:\WINDOWS\system32\VERSION.dll
ModLoad: 00c60000 00da7000 C:\Documents and Settings\max\Desktop\bin\fmodex.dll
ModLoad: 77be0000 77bf5000 C:\WINDOWS\system32\MSACM32.dll
ModLoad: 77c10000 77c68000 C:\WINDOWS\system32\msvcrt.dll
ModLoad: 76b40000 76b6d000 C:\WINDOWS\system32\WINMM.dll
ModLoad: 774e0000 7761e000 C:\WINDOWS\system32\ole32.dll
ModLoad: 71ad0000 71ad9000 C:\WINDOWS\system32\WSOCK32.dll
ModLoad: 71ab0000 71ac7000 C:\WINDOWS\system32\WS2_32.dll
ModLoad: 71aa0000 71aa8000 C:\WINDOWS\system32\WS2HELP.dll
ModLoad: 00db0000 00ffd000 C:\Documents and Settings\max\Desktop\bin\FreeImage.dll
ModLoad: 68b20000 68b40000 C:\WINDOWS\system32\GLU32.dll
ModLoad: 5ed00000 5edcc000 C:\WINDOWS\system32\OPENGL32.dll
ModLoad: 73760000 737ab000 C:\WINDOWS\system32\DDRAW.dll
ModLoad: 73bc0000 73bc6000 C:\WINDOWS\system32\DCIMAN32.dll
ModLoad: 01000000 0103c000 C:\Documents and Settings\max\Desktop\bin\glut.dll
ModLoad: 763b0000 763f9000 C:\WINDOWS\system32\COMDLG32.DLL
ModLoad: 5d090000 5d12a000 C:\WINDOWS\system32\COMCTL32.dll
ModLoad: 7c9c0000 7d1d7000 C:\WINDOWS\system32\SHELL32.dll
ModLoad: 77f60000 77fd6000 C:\WINDOWS\system32\SHLWAPI.dll
ModLoad: 76d60000 76d79000 C:\WINDOWS\system32\IPHLPAPI.DLL
ModLoad: 76380000 76385000 C:\WINDOWS\system32\MSIMG32.DLL
(b48.ce4): Break instruction exception - code 80000003 (first chance)
eax=00351eb4 ebx=7ffde000 ecx=00000003 edx=00000008 esi=00351f48 edi=00351eb4
eip=7c90120e esp=0022fb20 ebp=0022fc94 iopl=0 nv up ei pl nz na po nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000202
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll -
ntdll!DbgBreakPoint:
7c90120e cc int 3

can’t you run the application through the IDE in that machine and figure out where it’s crashing?

Sadly no. The the new OF does not even run examples on that machine. I get the “cannot create window” bug when using standard examples and just a straight fail if I use GLUT. I will try and put in some debug code to step through whats going on but I don’t think its even making it to setup() within ofApp.

It is odd older versions of OF (pre 0.7 odd) DO run and compile on it but then I run into my ofXML issue.

Thanks for the suggestions though!

is that in windows? most of the time this errors come from some unsupported gl functionality and are solved by installing newest drivers if it’s windows although it might just be an older graphics card that doesn’t support those functions at all. still seeing a stack trace from the debugger even if it doesn’t arrive till setup would be useful

Yeah windows. Thanks for the suggestions! I will try and see what data I can rustle up!