Cubieboard 2 (A20) not working

I know it is described in here:

https://github.com/openframeworks/openFrameworks/issues/2537

but for me it was a bummer. I thought that it was more or less compatible with Rpi, but as it turned out, no.

  
../../../libs/openFrameworksCompiled/project/makefileCommon/config.shared.mk:259: *** couldn't find some pkg-config packages, did you run the latest install_dependencies.sh?. Stop.  

Two weeks of expectations and whole day gone.

Ok, that was a bit lazy to whine. I tried headless setup, with no change. Same error. I will try to dive deeper into makefile bussiness and hopefully I will manage to get it somehow working

Hey, I’m doing the same here… Everything was installed correctly, but when you compile an OF example, just I got the same message like you…

Misconfiguration … That’s so sad :(, I will try to see what can I do on the weekend…

I have not touched CubieBoard for a while, but check this conversation on GitHub, seems like there is hope after all…

Good Luck!

hey… well, I have some small advances abou this.

First you need to install using synapic:
libglapi-mesa libgles1-mesa libgles1-mesa-dev libgles2-mesa libgles2-mesa-dev
then just check that all is configure
pkg-config cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal portaudio-2.0 openssl libpulse-simple alsa gl glesv1_cm glesv2 egl gtk+-2.0 libmpg123 --cflags
Now, I have an issue compiling one of the examples:

when I do make I got the following eror:
�������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������: File name too long make[2]: *** [../../../libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/3d/ofEasyCam.o] Error 127 make[1]: *** [Release] Error 2 make: *** [Release] Error 2 linaro@cubietruck:~/of_v0.8.0_linuxarmv7l_release/examples/gl/textureExample$
Not sure now what to do… any ideas??

I am not sure if this would help but I have a development branch that a couple of us have running on Allwinner SoCs. It runs in a framebuffer on the console using the mali drivers. Installation instructions can be found at: http://digitalhacksblog.blogspot.com/2014/02/openframeworks-sunxi-mfb-update-3-was.html.

digitalhack

hello,

I have just download the file from your git, bu there are issues. when I do the make i got he followong:

���������������������������������������������������������������������������������������������������������������������: File name too long
make[1]: *** [version] Error 1
make[1]: version/version: Command not found
make[1]: Entering directory `/home/linaro/Downloads/sunxi-mali-include-updates'
VERSION="" (Detected)
make[1]: version/version: Command not found
make[1]: version/version: Command not found
make[1]: version/version: Command not found
make[1]: version/version: Command not found
Makefile.config:54: Unknown/unhandled Mali Version ""
Makefile.config:55: Use VERSION=(r2p4,r3p0,r3p1) instead
make[1]: version/version: Command not found
Makefile.config:56: *** Unknown/unhandled Mali Version "".  Stop.
make[1]: Leaving directory `/home/linaro/Downloads/sunxi-mali-include-updates'
make: *** [config.mk] Error 2

I think here is a problem with make, but I don ge it. any ideas??

There is something fishy going on with your “make”; that “File name too long” thing is not supposed to happen. Do you just type “make” and this happens, or are you cutting/pasting all the lines in the instructions at once?

The path /Downloads/sunxi-mali-include-updates is also a bit suspect. You did not use git to get the sunxi-mali project, did you?

Hi, I have re-installed the full system.
For some reason, I can’t do make o any other sudo commands.

If I yped:

Make

I got this:

7\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377': command not found

if I do a sudo make

�����������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������: File name too long

Something is wrong…

Something is wrong…

Yep… The \377 stuff is not supposed to be there. Note that � is pretty much the same thing, just printed differently. Solve that first, and then try again.

I see that you are using Linaro? I am using Cubian (http://cubian.org) and it is working fine for me.

I was able to get OF on Cubieboard2 with latest Cubian os, It was a bit tricky to get it compile and to have hardware acceleration, but now it rocks.

Hello,

Can you share the general process for installation?

Thanks.

in order to get OF on Cubieboard2, I suggest to do something like this:

  • get the latest Cubian distribution (it may work with others linux variants, but I’ve tested Cubian and it works fine)
  • you have to make changes to OF_ROOT/libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.default.mk as it seems gles, gles2 and egl do not work with pkg-config in Cubian

comment out these lines:
PLATFORM_PKG_CONFIG_LIBRARIES += glesv1_cm
PLATFORM_PKG_CONFIG_LIBRARIES += glesv2
PLATFORM_PKG_CONFIG_LIBRARIES += egl

and add instead following lines:

PLATFORM_LIBRARIES += GLESv2
PLATFORM_LIBRARIES += GLESv1_CM
PLATFORM_LIBRARIES += EGL

  • now, as we want OF to use hardware acceleration we will have to install libsunxi-mali-x11 and libsunxi-mali-x11-dev packages if they are not already there.
    Unfortunately seems OF does not like the old GLES and GLES2 headers that come with libsunxi-mali-x11-dev and if you try to compile now you will face errors due to double definitions.
    I’ve solved in a dirty hackish way: I’ve overwritten gles and gles2 headers using mesa ones, personally I’ve downloaded libgles1-mesa-dev and libgles2-mesa-dev deb packages (only downloaded, not installed), extracted them and replaced the header files, but you can probably have a look at this fork of mali drivers that has newer headers https://github.com/digitalhack/sunxi-mali.
    Anyway, at this point I’ve compiled OF expecting a lot of link problems, but it went smooth and clean, and works beautifully with hardware acceleration.
    So far the only problem I’ve found is a link problem when trying to compile openCV addon, but if you search the forum you will find a solution, with a link to a working version of CV libraries for Cubieboard