Crypto-libexec failed on Raspberry1 while installing dependencies


Dear Open-Framework Community,

i just startet with OF and tried to set it up on my Raspberry PI 1.
I followed the instruction for installing the Framework on my Raspberry for developing.
While running the script i got the error:

Makefile:139: recipe for target ‘Crypto-libexec’ failed
make: *** [Crypto-libexec] Error 2

^ Received error ^

I tried to solve the problem with just reinstalling Debian on my raspberry but it didnt solve the problem.
Everytime i try to install the dependencies i get the same error againg.
This is the whole error:

src/CipherImpl.cpp:80:21: error: field ‘_ctx’ has incomplete type ‘EVP_CIPHER_CTX {aka evp_cipher_ctx_st}’
In file included from /usr/include/openssl/crypto.h:31:0,
from include/Poco/Crypto/OpenSSLInitializer.h:26,
from include/Poco/Crypto/CipherKeyImpl.h:24,
from include/Poco/Crypto/CipherKey.h:24,
from include/Poco/Crypto/CipherImpl.h:25,
from src/CipherImpl.cpp:17:
/usr/include/openssl/ossl_typ.h:90:16: note: forward declaration of ‘EVP_CIPHER_CTX {aka struct evp_cipher_ctx_st}’
typedef struct evp_cipher_ctx_st EVP_CIPHER_CTX;
/home/pi/openFrameworks/scripts/apothecary/build/poco/build/rules/compile:37: recipe for target ‘/home/pi/openFrameworks/scripts/apothecary/build/poco/Crypto/obj/Linux/armv6l/debug_static/CipherImpl.o’ failed
make[1]: *** [/home/pi/openFrameworks/scripts/apothecary/build/poco/Crypto/obj/Linux/armv6l/debug_static/CipherImpl.o] Error 1
make[1]: Leaving directory ‘/home/pi/openFrameworks/scripts/apothecary/build/poco/Crypto’
Makefile:139: recipe for target ‘Crypto-libexec’ failed
make: *** [Crypto-libexec] Error 2

^ Received error ^

I would be pleased if some may has an idea how to solve this problem or why this error appears.

Thank you very much.



Okay tried using the nightly build that let me install the codecs and the dependencies.

Now i gotta wait for the Compiler to finish.