coreLocation 0 | 0

Trying to run the core location example on iOS and it doesn’t seem to work -> only reports 0, 0. I have the Privacy - Location Usage, etc added to plist but it still doesn’t ask me permission to use location too…

In case anyone ends up here like me, 0 | 0 forever…
@ayruos mentioned the plist-file, so I read an article / something about plist-settings and location + privacy.
Resulting in: this in my ofxiOS-Info.plist file:

Still no luck.
The simple fix was to go on my phone (5S, iOS 11.2) and go to Privacy -> Location -> CoreLocationExample, and there I could set it to always, and ta-da: GPS!
There it also mentioned the “Hi” description (see image).
The app is still not asking permission though :confused:

A few years later and I am trying the same thing. Did anyone have any luck getting location on IOS with OF?

Ok, this eems a bit hacky. but I was able to get location by adding a line to (line 182) so it looks like this:

locationManager = [[CLLocationManager alloc] init];
[locationManager requestAlwaysAuthorization];
locationManager.delegate = self;
1 Like