Compilling OF 0.11 Manjaro error building Project Generator

I have been with a lot of troubles to compile OF, I am on Manjaro Linux, nor 0.11 nor 0.10 nor nightly for both from the site, nor AUR stable or nightly nor from github patch-branch nor master nor stable, I don’t know what more to do, I have tried to compile directly and also with archlinux helpers… why it is so difficult to start to use OF?

Do I need the Project Generator in order to work with OpenFrameworks? The fact is that OF compiles perfect but the Project Generator doesn’t, it is necessary at the time of work with OF or to export the project? or it is only necessary for generate new projects ?

Thanks in advance! I am looking forward to join with this amazing community, but I need to compile OF first!

Below the error, always it is the same error…

-> Building OF Project Generator tool…
Compiling OF library for Release
make[1]: Entering directory ‘/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project’
make[1]: Leaving directory ‘/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project’

Compiling projectGenerator for Release
make[1]: Entering directory ‘/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/apps/projectGenerator/commandLine’
/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project/makefileCommon/ *** missing separator. Stop.
make[1]: Leaving directory ‘/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/apps/projectGenerator/commandLine’
make: *** [/run/media/alexfreyre/WORK/SOFT/OPEN_FRAMEWORKS/AUR/openframeworks/src/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project/makefileCommon/ Release] Error 2
==> ERROR: A failure occurred in build().

I think this is a bug due to make 4.3.
There is an issue on GitHub.
See the following PR to fix it - it’s just one line.

when I manually open these files, in the first one I can correct the error, it is only a space in the second I can’t see the error, but the fact is when I correct the first one the compilation goes on and there is more error later… so the problem aren’t my OS nor me doing wrong things.

Why is so unstable OF, or the linux build isn’t tested by the developers?

There is only one file to correct

You should replace the line :

$(foreach var_line, $(subst $(space),?,$(shell cat $(addon)/ | tr '\n' '\t')), \`


$(foreach var_line, $(shell cat $(addon)/ | tr '\n ' '\t?'), \ 

Project Generator is a tool to help creating a new app. I, personnaly, do not use it. A copy/paste is generally enough.

Arch Linux (and its derivative) is hard to test as it is a moving release. So it may compile correctly the day OF is released but may not compile anymore the day after as a depency as changed. The community makes its best to support as many platforms as possible but sometimes it fails…
If you feel that the documentation are missing something, are obsolete or misleading, please feel free to submit an issue on Github.

1 Like

Ok, thanks for your answer. I could compile perfectly, the problem was “make” version which Manajro has currently 4.3 and it is needed 4.2.1 so I install it and everything was perfect! Thanks again! The answer was below in the github discussion that you post here, Arturo mentions the compatibility breaks because of make.