Compiling OF in raspbian Stretch


#42

Using the night version it ran and I tested a few examples there. This looks like a magnificent and powerful tool…I’ll start using this in some new programmes I’ll be developing in the RPi 3.

Inspite of being a superb tool - and am disappointed with the releases. I originally downloaded the release for Armv6 and this failed to compile and I lost time on that. Only when ayruos informed me that the nightly version must be used did the OF run.
I am not too keen on using nightly releases since the code may change after each night and so new problems may occur which may disappear on the next compile run. _The http://openframeworks.cc/versions/* must be able to run !


#43

I tested to install the nightly build into a fresh installation of stretch for a Pi 2B, everything compiled (slowly) but when trying to run my app i got the error:

ofAppEGLWindow: display(): eglSwapBuffers failed error.

So I ran sudo rpi-update and when rebuilding my app all the openFrameworks libraries were also recompiled (another long coffee break) but since then the app runs nicely.

ofxGPIO with latest patches works well.
I did have to rewrite the older ofXml code to the new syntax by looking at the supplied example.

Magnus


#45

I’ve managed to get this to work on a Raspberry Pi 3, Stretch and OF 0.9.8 using bakercp’s Method 1 ( brcm ).

I’ve tried a few examples and everything seems to compile (fast!) and run, but for some reason my mouse pointer doesn’t show up properly.
The arrow cursor is being drawn in only white, making it invisible on a white background. It looks like the normal black border has become 90% transparent.

does anyone know what could be happening here?

thanks,
Tim


#46

I have been stopped by ld not being able to find the lbcrmGLESv2 library.

Linking bin/emptyExample for linuxarmv6l
/usr/bin/ld: cannot find -lbcrmGLESv2
/usr/bin/ld: cannot find -lbcrmEGL
collect2: error: ld returned 1 exit status
/home/pi/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:403: recipe for target 'bin/emptyExample' failed
make[1]: *** [bin/emptyExample] Error 1
/home/pi/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:124: recipe for target 'Release' failed
make: *** [Release] Error 2

Tried to find it: find / -name “lbcrmGLESv2”
Nothing came back.

I am on a Pi 3 B with Stretch.

When is this lib generated? Do I need to install something else?

Any help would be appreciated.


#47

looks like a typo: brcm not bcrm


#48

Doh! always the simple things. I will get back to it and give it another go.

Thanks!


#49

Thanks @bakercp for your post earlier in this thread.

I think im close to getting the method 2 (mesa) approach to work headlessly usng Xvfb as a virtual framebuffer to run the sketch inside.

EDIT: steps towards a headless mesa approach here


#50

hey @ayruos, sorry for ask again… :wink: but there’s any chance that you share the sd image that you’re using ready to burn?


#51

Oh damn, I never got around making it, shit. And… I’m away from my Pi work desk for the next week or so :expressionless:


#52

Hey @TimK

Could you please share how you managed to make OF 0.9.8 work on Raspberry Pi 3?

Didn’t you get any error regarding Poco when you run install_dependencies.sh?

Thank you for your help.


#53

Hopefully we will still be able to use OF on the Pi in the future without the desktop.??

All my PI stuff works like this - not having to depend on a desktop environment is a benefit.


#54

Thanks for these instructions @bakercp

Just wanted to point out that ofAppEGLWindow.cpp has been modified since that post, and the lines in question to remove are no longer L440-L446 (for mesa method).

Look for the following code snippet to remove:

	////////////////
	// TODO remove the following ifdef once x11 is accelerated on RPI
#ifdef TARGET_RASPBERRY_PI
	if(isUsingX11) {
		isUsingX11 = false;
		ofLogWarning("ofAppEGLWindow") << "init(): X11 not availble on RPI yet, using a native window instead";
	}
#endif
////////////////

#55

How do you delete six lines from above code?


#56

… just backing on this “OF pi” way. thanks for al the tips
what’s the point of using today Archlinux vs Raspbian? What about the Raspbian Lite without desktop version?