compiler options for valgrind ( -g ) not working

I am not being able to pass the -g option to the compiler in order to run valgrind::memcheck;

i’ve tried using code::blocks’ compiler settings, as well as adding the -g flag on config.make (USER_CFLAGS); and even hardcoded it in the Makefile, but still no results, valgrind keeps telling me that i need to compile with the -g option enabled…

has anybody run into this?

thanks in advance

I’m having the same problem. I’m returning to OF after a loooong break.

When I try to run valgrind from the console I get errors about my code using unsupported bytecode. Maybe an amd64 thing?

pix

that’s weird the debug target has -g3 which should work with valgrind, it’s been a long time since i don’t use it but it used to work with 64bit without problem too