compilePG.sh fails


#1

Im trying to build the project Generator ./compilePG.sh, on Void Linux
I get the error:

➜ ./compilePG.sh
make: *** /home/eamoc/MyStuff/openFrameworks/apps/projectGenerator/commandLine: No such file or directory. Stop.
There has been a problem compiling the command line projectGenerator.
Any ideas folks? I’m stumped!


#2

Are you using OF from git? or the normal downloads from the web?


#3

OF from git.
Ill try downloading the site version and see how i get on.


#4

if you are using it from git you need to update the submodules using git clone --recursive or once you’ve cloned it with git submodule init; git submodule update

but yes the web downloads should work fine, try using the nightly builds though since it seems void is a rolling release and some things might be broken in the latest OF stable release due to some newer dependencies


#5

Ah, I see,
Many thanks for your reply

Eamonn


#6

Hi Arturo,
git submodule init; git submodule update
worked fine, however, I have now hit another snag.
A dependency of OF is a package called rtaudio ( https://www.music.mcgill.ca/~gary/rtaudio/)
This isn’t present as a package in Void Linux, so I installed manually.
Here is the directory listing of all the installed files

/usr/local/include/rtaudio
/usr/local/include/rtaudio/RtAudio.h
/usr/local/lib/librtaudio.a
/usr/local/lib/librtaudio.la
/usr/local/lib/librtaudio.so
/usr/local/lib/librtaudio.so.6
/usr/local/lib/librtaudio.so.6.0.0
/usr/local/lib/pkgconfig/rtaudio.pc

However, when I run compilePG.sh, I get this error

/bin/ld.gold: error: cannot find -lrtaudio
collect2: error: ld returned 1 exit status
make[1]: *** [/home/eamoc/MyStuff/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:399: bin/projectGenerator] Error 1
make[1]: Leaving directory ‘/home/eamoc/MyStuff/openFrameworks/apps/projectGenerator/commandLine’
make: *** [/home/eamoc/MyStuff/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:129: Release] Error 2
make: Leaving directory ‘/home/eamoc/MyStuff/openFrameworks/apps/projectGenerator/commandLine’
There has been a problem compiling the command line projectGenerator.

I’m wondering if there is something missing in my install?
Any ideas would be greatly appreciated!
Eamonn


#7

that would usually work but it might be that your system doesn’t recognize /usr/local/lib as a PATH for libraries. you can include that in the config.mk file in your projects and in the project generator before compiling it but you really don’t need the project generator in linux so you can just skip that step and already compile any of the examples in qtcreator or using makefiles


#8

Cool,
Thats great thanks.


#9

So I set up Qt Creator for OF, and it still doesn’t find the rtaudio library.
I edited config.make
$HOME/.config/QtProject/qtcreator/templates/wizards/openFrameworks/config.make
at line 79:
PROJECT_LDFLAGS=-Wl,-rpath=./libs += /usr/local/lib

This is the location on my hard drive of my libraries
➜ /sbin/ldconfig -p | grep rtaudio
librtaudio.so.6 (libc6,x86-64) => /usr/local/lib/librtaudio.so.6
librtaudio.so (libc6,x86-64) => /usr/local/lib/librtaudio.so

Don’t know what to do now!


#10

in qtcreator the config.make file doesn’t have any effect, you’ll need to add the path in the qbs file for the project or in the qbs for OF in libs/openFrameworksCompiled/project/qtcreator/of.qbs so it’s added to every project


#11

I’m new to Qt and Qbs,
I commented out the references to rtaudio in

libs/openFrameworksCompiled/project/qtcreator/of.qbs

and I’ll come back to it later. So Problem solved for now.
Many thanks for your help,

Eamonn