Compile v007 Leopard 10.5.8 Xcode 3.0

Hi all!
I was using release v062 with Xcode 3.0, everything working fine.
Because I needed some features present in v007 I downloaded OF v007 zip.
I opened GraphicsExample, and when compiling I get this error:

"Building… Checking dependencies…
error: There is no SDK at specified SDKROOT path ‘/Developer/SDKs/MacOSX10.6.sdk’
"

I looked at Developer/SDKs folder, and I have only MacOSX10.4u.sdk & MacOSX10.5.sdk.
MacOS10.6.sdk comes with Xcode 3.2, which can be installed if you have Snow Leopard, not my case.

This means that I cannot use v007 in Leopard?
Is there a way I can solve this? (Using the Terminal console, gcc, whatever…).
Any help is much appreciated!
Thanks.

Similar problem here.

The examples depend on openFrameworksLib.xcodeproj, where the Base SDK setting was “/DeveloperSDKs/MacOSX10.6.sdk”. I changed this to “Current Mac OS” for All Configurations, assuming it would now use the MacOSX10.5.sdk according to my system. But even when trying to build only openFrameworksLib.xcodeproj I get:

error: There is no SDK with the name or path ‘/Developer/SDKs/MacOSX10.6.sdk’

What about the static libs, as pointed to in CoreOF.xcconfig? Do they depend on the 10.6 SDK?

Katja

Sorry, overlooked this:

“We typically support the previous version of the latest OS X release.”

(from sticky thread http://forum.openframeworks.cc/t/poll:-should-we-drop-ppc-support—g4–g5-etc-/4733/0). Respective to OF 007, OSX 10.6 is the previous version of the latest OSX release.

Katja

Hi all,

this issue is solved, using this trick:

http://forum.openframeworks.cc/t/[solved-]-compiling-of-007-on-10.6-macosx-for-a-10.5-app-version-:-how-to-/9755/3

hope this help !

miguel.
www.tangilblex.net