'.compile.PG.sh' error on Fedora 33

Hi there,

I am trying to install and run projects with Qt on Fedora 33. I do not use Windows 10 anymore.

I had followed all of the instructions and everything seemed to work. But, when I tried to install the project generator using this code:

tcd OF/scripts/linux
./compilePG.sh

I received an error that I needed to report to the forums.

Here is a the snippet:

[tomr20@localhost linux]$ ./compilePG.sh
make: Entering directory '/home/tomr20/Documents/OF/apps/projectGenerator/commandLine'
Compiling OF library for Release
make[1]: Entering directory '/home/tomr20/Documents/OF/libs/openFrameworksCompiled/project'
Done!
make[1]: Leaving directory '/home/tomr20/Documents/OF/libs/openFrameworksCompiled/project'


Compiling projectGenerator for Release
make[1]: Entering directory '/home/tomr20/Documents/OF/apps/projectGenerator/commandLine'
/home/tomr20/Documents/OF/libs/openFrameworksCompiled/project/makefileCommon/config.addons.mk:210: *** missing separator.  Stop.
make[1]: Leaving directory '/home/tomr20/Documents/OF/apps/projectGenerator/commandLine'
make: *** [/home/tomr20/Documents/OF/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:129: Release] Error 2
make: Leaving directory '/home/tomr20/Documents/OF/apps/projectGenerator/commandLine'
There has been a problem compiling the command line projectGenerator.
Please report this problem in the forums.
[tomr20@localhost linux]$ 

Please let me know how to get pass this. And also if there any other guides to use Qt and linux than on the Open Frameworks website.

My full project was to use ‘ofxTwitter’ with Qt, but I still have errors with it.

Thank you.

T0mR

I guess I might have found the issue.

I found similar question to mine. This may be the GCC compiler version which I downloaded the wrong version of. I had downloaded the version GCC 6.0.

I ran this command to check:

[tomr20@localhost linux]$ uname -a
Linux localhost.localdomain 5.10.12-200.fc33.x86_64 #1 SMP Mon Feb 1 02:40:52 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

My version is only 5.10. So that might be the issue, right here.

I will get the older package and keep my post updated in case of any arising issues.

T0mR

I guess I got confused here.

facepalm

I printed out the information about the Linux system, not the GCC compiler. So, that is just the kernel version.

I ran this command instead:

[tomr20@localhost ~]$ gcc -dumpversion
10

This confirms I have a GCC compiler of 10. Not 5.10.

So, I had the right version. ‘GCC and above.’

T0mR

Still not working by the way.

Any help is appreciated.

Thanks.

T0mR

Hi @T0mR and welcome to the forum
Maybe you’ll find this post useful:
https://forum.openframeworks.cc/t/missing-separator-for-addons-with-addon-config-mk/34488/6

HTH

Hi Bencilari,

Was a long time user of OpenFrameworks for projects of me. Now I am finally on the forum. It is a good feeling.

Thanks for the reply. I will have a look. :slight_smile:

T0mR

Hi Bencilari,

Unfortunately I am still having issues with it.

Thanks.

T0mR

The error is saying there is a missing separator issue. If you google that you will find a solution: