codeblocs error after upgrading to Ubuntu Karmic

I followed arturo’s instructions and ran

sudo apt-get install libdrm-dev  

followed by running the new script. This resulted in the same error altern had, doing the following fixed it:

sudo apt-get update  
sudo apt-get upgrade  

this then installed the libwxgtk2.8-0 package which then enabled codeblocks to run.

However now I’m having problems both with the movieGrabberExample and moviePlayerExample. The grabber fails to find my build in camera (probably identical to yours arturo), and the file plays, but the output looks corrupted and it eventually segfauls. I can run cheese successfully, haven’t tried ucview.

The grabber fails to find my build in camera (probably identical to yours arturo

my computer died so can’t try with that camera : (

are you trying with unicap or gstreamer?

i’ve found a problem with the videoplayer in karmic as by default gstreamer uses now rgba, so you need to specify the depth in the pipeline. i have it working. going to pack it and upload it.

my codeblocks even didn’t start after i installed a fresh karmic 32bit.

this solved my problem:

just add deb jaunty-wx main
to your software soruces and do a update & upgrade.

got it from here:…-1.msg77976


the problem is that da still want to install the old hardy stuff:
line from the file:
WX_DEB=“deb hardy-wx main”


just got some errors with my fresh installation:
i also need the libunicap-dev package and the gstreamer0.10-ffmpeg package to start the movieplayer example.
i think you should add this to the script or think about to change to a more free video format?!

benben, you will find that arturo already included a new codeblocks install script in this thread which fixes that problem.

i’m sorry, didn’t noticed that one. but its good when its already fixed! :slight_smile:

I just upgrade some packages and I’m getting this error again:

relocation error: /usr/lib/ symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file with link time reference

Can’t seem to fix it this time…I think I’m going to have to compile CB from source which is annoying. Looks like codeblocks is not up to date with the latest wxwidgets library in Karmic.

try in synaptic preferences > distribution: always prefer: jaunty-wx

that will make all wx-widgets related packages to be installed from the wx repositories instead of the ubuntu one.

then update & upgrade to change the packages to the original ones.

i’m looking for a way of doing this automatically from the script

I switched to wx-jaunty in Synaptic > Settings > Preferences > Distribution > ‘Prefer versions from’… ran sudo apt-get update then sudo apt-get upgrade, and no luck. It doesn’t seem to think anything needs upgrading. Same if I run or sudo apt-get install libdrm-dev - it thinks everything already has the latest versions, so it doesn’t need to worry.

(still get the same error when I run codeblocks)

Unfortunately that didn’t work for me either…I had to install codeblocks from source.

same for me. tried arturo’s workaround, but that didn’t help, too :frowning:


see the karmic thread

You mean this thread?

…Still getting the same

codeblocks: relocation error: /usr/lib/ symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file with link time reference  

can you try setting jaunty-wx as preferred repo and doing the update & upgrade from synaptic instead of command line?

if it doesn’t recognize any new versions, uninstall codeblocks, apt-get autoremove and then reinstall from synaptic

oh dear, curses and double curses! I had codeblocks working fine with arturo’s file that is the wx-widgets from jaunty-wx. Then I clicked on the karmic upgrade without looking at which packages it wanted to upgrade and now I have the same problem as Oolong.

I ran the script again modified with --reinstall as an option in the apt-get install just for good measure.

I still have the problem.

I will dig around a bit but if anyone has a quick recipe I would be most grateful.

I see in synaptic that if I choose libwxbase2.8-0 and I choose Packages->Force Version, I can choose which version will be used. I have three in the list, the karmic default one, and the jaunty-wx 2.8.10-0 and also a jaunty-wx 2.6.10-1 one. I tried both the jaunty-wx ones and they didn’t work.

uninstall and reinstall of codeblocks is not working either

aaargh so confusing, now I forced the libwxbase2.8 and libwxgtk2.8 to use the karmic repository version and codeblocks works again.

this is the solution that worked for me, i added the source list that benben posted about here:

and when i checked my libwxbase2.8-0 package in synaptic , i had these packages available for me to force: (jaunty-wx) (karmic) (jaunty-wx) (hardy-wx) (hardy-wx) (hardy-wx)

and i force the (karmic) version (even if i was warned it would be a downgrade) and now codeblocks works again! :smiley:

otherwise it doesn’t seem i need to touch libwxgtk2.8

Same here - forcing “ (karmic)” in Synaptic solved the launch problem for me as well.
Thanks for posting!

I’ve just moved to karmic and too have

codeblocks: relocation error: /usr/lib/ symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file with link time reference

i’m trying to do as in the previous post but doesn’t show up in the search synaptic despite changing preferences for distribution etc.

any ideas ?

Hey the 0061 release should be ready to roll for Karmic.
You can grab it here:

same problem occurs on 10.04 when upgrading from libwxbase2.8.10.1-0ubuntu1 to Downgrading via synaptic solves the issue.

Made a bug report here:…-bug/623989

confirm luopio’s observations. the bad version is in the lucid-updates repository.

you will have to file a bug report with the code:blocks developers, though, as this guy at launchpad correctly observes.