codeblocks script for 0.7 on Ubuntu Ocelot

I’m getting this when I try to run the install_codeblocks.sh script in linux/ubuntu :

  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  
  
The following packages have unmet dependencies.  
 codeblocks-contrib : Depends: libwxsmithlib0 (= 10.05-2) but 10.05svn7655-1 is to be installed  
                      Recommends: valgrind but it is not going to be installed  
E: Unable to correct problems, you have held broken packages.  
  

Is the install_codeblocks script up-to-date for Ubuntu 11:10 ?

cheers

phil

it seems like you had some additional repository configured. probably from an old OF install? take a look at /etc/apt/sources.list.d if you have any of wxwidgets.list or cb-nightly.list remove them, then execute remove_codeblocks.sh (it’s in the same directory as install_codeblocks.sh) and try to execute install_codeblocks again