codeblocks libwxbase problem

(On Karmic 9.10)

Update packages cruelly tricked me into upgrading my libwxbase which now means that my codeblocks no longer works.Its the same problem as in the post below.

http://forum.openframeworks.cc/t/[solved]-recent-update-of-codeblocks-or-libwxbase-broken/4012/1

I tried the fix there but I get …

Version ‘8.02svn6088’ for ‘codeblocks’ was not found

I used to just force the version in synaptic like described here

http://forum.openframeworks.cc/t/codeblocs-error-after-upgrading-to-ubuntu-karmic/2784/22

but now the install_codeblocks script is changing the version of libwxbase back again. Any ideas of how I can solve this ?

are you using 32 or 64 bits?

thanks arturo I’m using 32-bits

ok, i’ve changed the online check of the install dependencies script, i suppose it should work now. try also cleaning the apt cache as it’s explained in the setup guide:

http://www.openframeworks.cc/setup/linux-codeblocks

thanks,

do you mean on the site downloads page or github … git hub seems unchanged … could you post a link

k

no, the install dependencies script does an online check to know what version to install, since it changes very often and was difficult to mantain, so you just need to execute the same script that you already have and it will know what to do :slight_smile:

thanks,

I tried it all … but still the same :frowning:

K

okay I’m really at a loss now. I’ve just finished upgrading my laptop to Lucid,cleaned the cache and reinstalled of and codeblocks and still the same error !

yet it works on my 2nd laptop ?

I’m pretty much resigned to a complete reinstall of Ubuntu … unless you could suggest anything else. :cry:

S

phew solved it in Lucid by forcing version of libwxbase to the one with ubuntu1 at the end …